How to fix 'Unrecognizable database format'

I have an access application developed in Microsoft Office Professional 2010 Access version 14.0.7192.5000 (32 bit).  It has a backend database.  I install using SageKey Installation Wizard which includes the Microsoft Runtime 2010.

It installs and runs fine on most versions of Windows and office, including Windows 10 and Office 365, including 2 in my office.  BUT on just a few client machines running Windows 10 and Office 365, it gives an error 'The expression you entered has a function name that [the application] can't find.'

I tried to open the backend database in Access 16 and got 'Unrecognizable database format'  

Can anyone tell me why and how to fix it?

Many thanks in advance.

CRB
Clive BeatonAccess DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam Simon NasserIT Support ProfessionalCommented:
make sure that you have windows and office are up to date. update and check.
Gustav BrockCIOCommented:
'Unrecognizable database format'  means that the file has been corrupted. However, opening it in Access 2016 cannot do this.

That doesn't happen normally, so either your distributed file is not good (should not be the case), or the file has somehow been handled improperly at the client's machine.
Clive BeatonAccess DeveloperAuthor Commented:
Updates are right up to date.  Today, in fact.
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

Fabrice LambertConsultingCommented:
Hmm, this kind of message is rarely a good news.

Make a backup of your database.
Try to open it with a full access, then compact it.

If that fail, I'm afraid the database is corrupted.
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
<< BUT on just a few client machines running Windows 10 and Office 365, it gives an error 'The expression you entered has a function name that [the application] can't find.'>>

 This is a sign of broken references.  Something in the target environment that you have set a reference for in the app is not the same.

<<I tried to open the backend database in Access 16 and got 'Unrecognizable database format'  >>

 This may not be a corrupt DB.   What format is your DB in?    Access 2013 and up will no longer read a JET DB in 3.x format.

Jim.
mbizupCommented:
Is this a shared back end, opening on some machines but not on others, all with the Windows 10 / Office 365 setup?  Or are you able to copy the 'broken' back end to another computer and open it successfully?  If so, I would think that you are missing some component in your Access installation on the troublesome computers.
Gustav BrockCIOCommented:
I would address this issue to SageKey support.
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
Also be aware that with Access 2016, when they added BigInt support, there is an upgrade of the db version.   This is currently only available in O365.  Someone with a retail version of Access or the runtime would get the "Unrecognizable database format" message.


little info on that here:

https://support.office.com/en-us/article/using-the-large-number-data-type-5b623f6e-641d-4e97-8bdf-b77bae076f70#compatibility_considerations

Jim.
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
BTW, if you back up a bit on the page from that link, it tells you how to check the DB version.

Jim.
Clive BeatonAccess DeveloperAuthor Commented:
Thank you all, very much.  I am digesting this and trying some of the suggestions.  Bear in mind that I can only do this on client machines, so it takes a bit of time.  I also have the problem that the client data is protected by law and I may not be able to put their data on my machine.

This is threatening my business as clients are already looking for other products, so I am taking this very seriously.

I will get back to you.
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
on this:

"I tried to open the backend database in Access 16 and got 'Unrecognizable database format'  "

Something to be aware of:

https://support.office.com/en-us/article/access-error-this-database-is-in-an-unrecognized-format-when-opening-access-runtime-application-accde-file-5ed21574-cbff-498b-878e-7bff5b77933f?ui=en-US&rs=en-US&ad=US

 Don't know if it applies or not, but make sure the Office 365 crowd is up to date on their patches.

Jim.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Clive BeatonAccess DeveloperAuthor Commented:
Many thanks to all of you.  Glad to see that MS have fixed the bug.

In the end I recreated the system under Access 16, which would have been messy for downloading from my website.  At least it worked and proved that the database was not corrupt.

It's so good that you hung in there.

CRB
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.