Office 2016 PROPLUS failed installation

Tried to install Office 2016 PROPLUS on windows 10 pro with Office 2013 PROPLUS installed.  Tried to install as an upgrade to 2013 and also as a separate install leaving 2013 installed as well.  Both have failed.  Gives me a 1603 error.  The error seems to be indicated at time 13:07:12:109 in the log file (see log file snippet below).  I'll be glad to forward the entire log file if need be.

However, I'm not smart enough to figure out exactly what the problem is.  Anyone out there that can look at the log file and give me an indication of what the problem is with the install.

FYI.  The install is doing this on two computers, however, it installed correctly on one computer with the same windows 10 pro and Office 2013 PROPLUS

installed and the computers are the same Dell desktop with same antivirus, etc.

LOG FILE SNIPPET......

2018/01/15 13:07:11:468::[1236] MSI(ACTIONSTART): 'Action 13:07:11: RestartSearchService. '
2018/01/15 13:07:11:468::[1236] MSI(INFO): 'Action start 13:07:11: RestartSearchService.'
2018/01/15 13:07:11:471::[1236] MSI(INFO): 'Action ended 13:07:11: RestartSearchService. Return value 1.'
2018/01/15 13:07:11:472::[1236] MSI(ACTIONSTART): 'Action 13:07:11: InstallFinalize. '
2018/01/15 13:07:11:472::[1236] MSI(INFO): 'Action start 13:07:11: InstallFinalize.'
2018/01/15 13:07:11:477::[1236] MSI(COMMONDATA): 'Message type:  0, Argument:  0'
2018/01/15 13:07:11:477::[1236] MSI(COMMONDATA): 'Message type:  1, Argument:  Microsoft Office Professional Plus 2016'
2018/01/15 13:07:11:478::[1236] MSI(ACTIONSTART): 'Action 13:07:11: CryptRegAction. '
2018/01/15 13:07:11:524::[1236] MSI(INFO): 'CryptRegAction:  Registering the Office Provider.'
2018/01/15 13:07:11:528::[1236] MSI(ACTIONSTART): 'Action 13:07:11: MsoHtmEdSelfReg. '
2018/01/15 13:07:11:755::[1236] MSI(ACTIONSTART): 'Action 13:07:11: CAPopulateSPPCache. '
2018/01/15 13:07:11:802::[1236] MSI(INFO): 'CAPopulateSPPCache:  OMSICA : Initializing CustomAction CAPopulateSPPCache'
2018/01/15 13:07:11:881::[1236] MSI(ACTIONSTART): 'Action 13:07:11: CARegisterHeartbeat. '
2018/01/15 13:07:12:054::[1236] MSI(INFO): 'CAQuietExec:  ERROR: The system cannot find the file specified.'
2018/01/15 13:07:12:054::[1236] MSI(INFO): 'CAQuietExec:  '
2018/01/15 13:07:12:057::[1236] MSI(INFO): 'CAQuietExec:  Error 0x80070001: Command line returned an error.'
2018/01/15 13:07:12:057::[1236] MSI(INFO): 'CAQuietExec:  Error 0x80070001: CAQuietExec Failed'
2018/01/15 13:07:12:058::[1236] MSI(INFO): 'CustomAction CARegisterHeartbeat returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)'
2018/01/15 13:07:12:109::[1236] MSI(INFO): 'Action ended 13:07:12: InstallFinalize. Return value 3.'
2018/01/15 13:07:12:112::[1236] MSI(COMMONDATA): 'Message type:  2, Argument:  0'
2018/01/15 13:07:12:112::[1236] MSI(COMMONDATA): 'Message type:  2, Argument:  0'
2018/01/15 13:07:12:113::[1236] MSI(COMMONDATA): 'Message type:  0, Argument:  0'
2018/01/15 13:07:12:113::[1236] MSI(COMMONDATA): 'Message type:  1, Argument:  Microsoft Office Professional Plus 2016'
2018/01/15 13:07:12:113::[1236] MSI(ACTIONSTART): 'Action 13:07:12: Rollback. Rolling back action:'
2018/01/15 13:07:12:114::[1236] Log level changed from: Standard to: Verbose
2018/01/15 13:07:12:116::[1236] MSI(COMMONDATA): 'Message type:  2, Argument:  1'
2018/01/15 13:07:12:119::[1236] MSI(COMMONDATA): 'Message type:  2, Argument:  0'
2018/01/15 13:07:12:189::[1236] MSI(COMMONDATA): 'Message type:  0, Argument:  0'
2018/01/15 13:07:12:189::[1236] MSI(COMMONDATA): 'Message type:  1, Argument:  Microsoft Office Professional Plus 2016'

END SNIPPET...

Warren
Member_2_6008897Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
Try to find and delete this folder: MIcrosoft\Office
in your Task Scheduler. Then try the installation again.
0
Member_2_6008897Author Commented:
Thanks for your quick reply.
I didn't want the initial post to be so long (with the snippet,etc.) so I left out a few things that I have already done to try and solve the problem.
This is a bit complicated but bear with me.
I did delete the Microsoft\Office folder in Task Scheduler.  That did not help.  After deleting the folder I then tried to run the following command:
"schtasks.exe" /create /f /tn "Microsoft\Office\Office 15 Subscription Heartbeat" /ru SYSTEM /xml "C:\Program Files\Common Files\Microsoft Shared\OFFICE16\HeartbeatConfig.xml"
That failed (see attached screen shots).
I also tried to add the task via the GUI and it failed as well (see attached screen shots).
I hope the screen shots help.  I tried as many different things as possible with still the same failed installation of Office 2016.

Is any of this maybe tied to the registry somehow so that the registry thinks the heartbeatconfig.xml file is actually somewhere else than the standard location?

Any help you could provide to sort this all out would be very much appreciated
command-line.jpg
office15.jpg
office16.jpg
task-already-exists.jpg
SetupExe-2018011513024326C4-.log
0
KimputerCommented:
Keep ALL those Office stuff removed from task scheduler (after all, during a fresh install, they're not there either).
Then do a full uninstall of Office 2016 and 2013:
https://support.office.com/en-us/article/uninstall-office-from-a-pc-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8#OfficeVersion=2013
https://support.office.com/en-us/article/uninstall-office-from-a-pc-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8#OfficeVersion=2016

Use the easy fix app (so do it twice). Reboot. Now finally do a fresh install.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Member_2_6008897Author Commented:
OK.  I'll give it a try.  The computer is at a client location and I'll probably be there next week.  Office 2013 is still installed and running just fine, so there is no real urgency...

Warren
0
Warren SmithCommented:
OK.  So here is what the problem was.

Somehow, the registry got "messed" up and only had partial information about the task for the Office heartbeat.

Therefore, when I opened the task scheduler GUI it showed that there was an office folder in task scheduler but it did not show any tasks in it (even though the registry did).  Furthermore, I could not delete the Office folder in task scheduler (keep saying the logged in user did not have permissions to delete the office folder (even though I was logged with administrator privileges and ran task scheduler as "run as administrator")).  So what to do.

Well, task scheduler holds all its tasks in the "%windir%/system32/tasks" folder.  So I deleted the "../tasks/Microsoft/Office folder".  Also, there are a couple of registry entries regards the task scheduler.  They are "hklm/software/microsoft/windows nt/current version/Schedule/taskcache/tasks" and "hklm/software/microsoft/windows nt/current version/Schedule/taskcache/tree".  

When I opened up the ...taskcache/tree registry entry there was a subkey for "Microsoft/Office",   Inside that key, there was an ID  entry that contained a GUID that pointed to a folder inside the ...taskcache/tasks registry entry.  So I looked for the GUID under  the "...taskcache/tree/Microsoft/Office" registry entry and used that GUID to locate the correct entry in the "...taskcache/tasks" registry key.  Then I delete the key that matches the GUID under the ...taskcache/tasks" key and then delete the "Microsoft/Office" entry under the ...taskcache/tree" registry entry.

Once that was done, Office 2016 install -- no issues.

I don't know if using the Easy Fix app tool for Microsoft Office would have gotten rid of all the bad registry entries or not (some of the google search result entries regards all this indicated that running the easy fix app did not solve the problem and Office 2016 still failed to install), but I was curious as to what was the underlying issues here for the failed install, so I kept digging until I figured it out.

Also, sorry for the long entry (I'm sure a few screen shots would have been much better at showing what needs to be done), but alas, I forgot to take them as I was working the issue, and I am now no longer at the location that had the install issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Warren SmithCommented:
issue resolved
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.