Exchange 2016 Permissions

Good Morning,

We are having permissions issues with deleting mailboxes, and also trying to modify our Receive Connectors.  I have attached the error message we are getting.  I have Googled many articles, to verify specific permissions, and they appear to be setup correctly.  Has anyone encountered this before?  Thank you in advance.
Exchange-Error.jpg
J DSystems AdministratorAsked:
Who is Participating?
 
J DConnect With a Mentor Systems AdministratorAuthor Commented:
I found the solution.  I went into the Virtual Directories, and looked at the ECP authentication, and that wasn't configured correctly for some reason.  I applied the change back to where we had it, and I'm now able to apply changes, delete mailboxes, etc.  Thank you for your time, and I hope you have a good rest of your day.
0
 
Todd NelsonConnect With a Mentor Systems EngineerCommented:
The educated guess would be that you do not have the required Exchange permissions to perform those tasks.


Organization Management will give you the ability to do what you need.
0
 
J DSystems AdministratorAuthor Commented:
Thank you for your prompt reply.  We have verified the permissions in our Organization Management, and everything is set to what it always has been.  What's odd is, just last week we removed a couple of mailboxes, without error.  We go and try it yesterday and today, and we are getting this.  We restarted the Exchange server last night, as well as the DC's, just FYI.
0
 
J DSystems AdministratorAuthor Commented:
It took a little digging, but we discovered that the authentication options in ECP virtual directory were not configured correctly.  Another tech had confirmed this was altered for "testing", but was never changed back.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.