Keyboard and mouse don't work

I have an ASUS desktop running windows 10 home. The mouse and keyboard don't work when windows boots up. Tested keyboard and mouse on other pc and it worked fine. used every usb port on the problem machine and still nothing. Attempted to use a ps/2 mouse and the same issue is happening. Steps taken:

1. booted into bios, keyboard works. made sure usb ports were enabled
2. rebooted still didn't work.
3. booted into safe mode and they still don't work.
4. attempted system restore but no restore points are available.
5. had to go into command prompt start up and enable ps/2 mouse, disabled and enabled usb ports .
6. booted into safe mode and ps/2 mouse works but still no usb.
7. attempted to update drivers on mouse and keyboard, but says windows was unable to install the driver.
8. Manually downloaded drivers onto flashdrive from other pc and still couldn't install the drivers.

Wired Mouse and Keyboard are both Asus, also tried Wired Dell mouse and keyboard.
Any ideas?
ebsadminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason JohanknechtIT ManagerCommented:
Yes, this problem is growing.  I have one, and I cannot get it to remove the pending action yet.  What CPU do you have?  Trying to collect more info to help on my issue.
0
Jason JohanknechtIT ManagerCommented:
The DISM command returns:
This version of %1 is not compatible with the version of windows your running....  (64-bit is the OS).
Error: 216


The CPU is an i3-2120.  HP Touchsmart 420.  Windows 10 Pro 64-bit
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

ebsadminAuthor Commented:
I saw the windows update solution before hand and attempted to remove it but my pc locks up and won't remove the update. Can't kill it in task manager either. Sorry I didn't include this. It finally removed it but still have the same issue.
0
Jason JohanknechtIT ManagerCommented:
Do you have the input.inf file in windows\INF folder?
0
ebsadminAuthor Commented:
The problem overall was the update. I deleted the update initially, but when it restarted the update was still there after looking. I then checked to see if any antivirus was running and nothing was. reactivated Norton and ran a virus scan in safe mode and it removed a virus and had no problems deleting the update afterwards. restarted and everything is working now. Thank you.
1
Joe Winograd, Fellow&MVEDeveloperCommented:
> reactivated Norton and ran a virus scan in safe mode and it removed a virus and had no problems deleting the update afterward

That's an interesting twist! Thanks for letting us know.

> restarted and everything is working now. Thank you.

You're welcome. Very glad to hear that. Regards, Joe
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.