Black Screen after login 2008srv

Have a 2008srv that is running but not accessible from the console or RDP. It only shows a black screen after login. This is physical server (no VM guest), and we really do not want to forcibly shut it down. There is a db process that *must* be closed gracefully.

Found several similar posts, but none of the solutions have worked thus far.

CTRL - ALT - DEL and CTRL - ALT - END will act like they are bringing something up, but then just go back to black.

I can remotely access the services, and have tried restarted Terminal Services and a few other related ones, but the problem persists.

Already tried all the workaround shown here -

Any ideas would be greatly appreciated.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dean ChafeeIT/InfoSec ManagerCommented:
Usually this problem is associated with the one profile/user logon. Have you tried a different user/profile?
You can also remote query the sessions and force logoff the problem user/profile like this:

at CMD

C:\Temp>query session /server:MyServerName

 SESSIONNAME       USERNAME                 ID  STATE   TYPE        DEVICE
 services                                    0  Disc
 console                                     1  Conn
 rdp-tcp#2         Mr.User                   2  Active
 rdp-tcp#0         User2                     3  Active
                   Mrs.User                  4  Disc
 rdp-tcp#1         User3                     5  Active
 rdp-tcp                                 65536  Listen

Open in new window

Then you can force logoff the problem session/user by ID:
C:\Temp>logoff 4 /server:MyServerName

This would force logoff the session with ID 4.  This requires CMD open in run as administrator mode.

Once logged off, try the RDP session again.

rastoiWindows DTS expertCommented:
@ Dean -  good hint.
@ ziceman - It can be additionally caused by:
1. lack of diskspace on system or userprofile location volume
2. depleted memory or handles on system

if are you able to connect remotely to the services you can as well query remotely resources. I preffer sysinternals tools for this purpose especially psmon is helpful to see handles and memory.
zicemanAuthor Commented:
Thanks to both of you.

The suggestion of Sysinternals actually got me going in the right direction.

While the Query Session option did not return anything, I was able to use PsExec to get access to a remote CMD session. This allowed me to manually execute commands to gracefully shutdown the needed key processes.

Nothing worked to get the GUI back - locally  at the console or via RDP, so I ended up using the power button. System came back up OK. Have not yet had a chance to review the event logs to determine the cause.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zicemanAuthor Commented:
No other recommendation solved the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.