WSUS clients not reporting after upgrade

We recently upgraded our WSUS to a windows 2012 server following the process outlined in one of the articles on the web  http://www.careexchange.in/wsus-3-2-win2008-r2-to-6-3-win2012-r2-step-by-step/. The upgrade process went to plan, I deleted the original wsus server after taking a complete backup and the new machine was added to the domain with the original name and IP address. For some reason none of the clients are reporting back to the server. I have attached a  log from my workstation where you can see that it is complaining that it cannot contact the web-server

[webserviceinfra]WS error: There was an error communicating with the endpoint at 'http://mpau-wsus/SimpleAuthWebService/SimpleAuth.asmx'.

I am stuck with how to proceed from here. Any help would be appreciated
WindowsUpdate.log
Venkatesh SrikantiahAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Venkatesh SrikantiahAuthor Commented:
Just to clarify, I have even changed the port number to reflect 8530 on the group policy to http://servername:8530
0
Von AndersonCommented:
What is the TTL for your DNS?  Even if you are using the same Name and IP the network interface of the WSUS server has a different mac address.  It is possible that the arp tables on your servers have the ip associated with the mac of the original WSUS server.  If you flush the dns cache of your servers it will resolve the issue.   Test it on one of your servers experiencing the problem.

Ipconfig /flushdns

You can also delete the ip address from your arp cache

arp -d <Your WSUS Server IP>
0
Venkatesh SrikantiahAuthor Commented:
Von
I have checked all these and and deleted the arp cache as well and have had no luck with the same.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Von AndersonCommented:
Have you ruled out the firewall on the WSUS server?  Is it configured to allow WSUS traffic utilizing that port?
0
Venkatesh SrikantiahAuthor Commented:
Yes that was automatically configured as part of the installation and it has allowed both ports 8530 and 8531. The only thing I just noticed is on my DC I updated the Group policy to reflect the "Specify Intranet update service location to reflect http://mpau-wsus:8530 and did a gpupdate and on the client machine it does not change anything at all. Even If I specify the port on the client machine going into the registry, Once I do the GPupdate /Force it changes back to http://mpau-wsus without the port number which is clearly stated in the GPO. I am a bit confused with this.
0
Venkatesh SrikantiahAuthor Commented:
Sorry that was my mistake I was updating the wrong policy. Group policy is not the issue here
0
arnoldCommented:
Use gpmc to query whether the change applied.

The question to which Von's question suggests the use of a hostname unrelated to the servername hosting the wsus services.
This way, you do not have to wait until the change of the gpo to reflect the new server for wsus propagates to the client (potentially since update settings are part of computer gpo 90 minutes to refresh policy or after a reboot.
Using wsusupdate.myaddomain.siffix as the hostname, while within DNS directing this CNAME or A record to the servername or ip of servername.
This transition is only delayed by the DNS propagation, or through ipconfig /flushdns on the client system where you want .......

Look at the c\windows\windowsupdate.log to see what happens when it is attempting to check in with a wsus server.

Double check the servername network center, to which network type is it set, private, domain, public.
Based on that look at the advanced firewall inbound to make sure the two ports 8530/8531 are scoped on the network ...
0
Venkatesh SrikantiahAuthor Commented:
I think it was mainly the group policy issue where I was updating the wrong one with the port number. The problem got resolved straight after that was amended on the right GPO. Thanks for all your input and @Arnold I will make that change as well so we do not wait for the gpo update to happen and a very valid suggestion.

Regards
Venkatesh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: Venkatesh Srikantiah (https:#a42484907)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.