Message Size Exceeds Size Limit Even Though Limit is Higher

Our client often gets complaint's from their customers not being able to send attachments through to them because they continuously get rejected for being too large.

They're using an on-prem 2010 Exchange server.  
The initial message size limit send/receive was set to 30MB.
Their hosted anti-spam solution, Trend micro, has a limit set for 50MB.
I changed the on-prem 2010 Exchange server send/receive to a limit of 50MB for troubleshooting purposes.

We still get bounce backs when sending anything typically over the size limit of 15MB. The message comes back indicating it exceeds the limit of 20MB.  After checking all the settings (that I know of), I don't know where the size limit of 20MB is being set.  I know that messages grow in size beyond the initial attachment limit, but not to this degree.

Is there anything specifically I've missed in checking?

Thank you!
servicadAsked:
Who is Participating?
 
Jason CrawfordConnect With a Mentor Transport NinjaCommented:
Check these four locations:

Get-TransportConfig | Select-Object MaxReceiveSize,MaxSendSize
Get-ReceiveConnector | Select-Object name,MaxMessageSize
Get-SendConnector | Select-Object name,MaxMessageSize
Get-Mailbox -ResultSize unlimited | Select-Object name,MaxSendSize,MaxReceiveSize

Open in new window

1
 
timgreen7077Connect With a Mentor Exchange EngineerCommented:
check the size limits on the send and receive connectors, and the organizational level settings.
0
 
servicadAuthor Commented:
Hi Jason Crawford,

Thanks for these!  The transport config is reflecting what was changed to 50MB.  The Receive and Send Connectors are showing 20MB so this is where the issue relies.  I know how to modify the send connector but cannot find the settings in the EMC to modify the receive connector.

Thanks!
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Jason CrawfordTransport NinjaCommented:
If you want to modify all ReceiveConnectors, do this:

Get-ReceiveConnector | Set-ReceiveConnector -MaxMessageSize 50MB

Open in new window

If you want to modify only one Receive Connector, do this:

Set-ReceiveConnector '<Receive Connector Name>' -MaxMessageSize 50MB

Open in new window

I don't know how to modify the setting in EMC either :)
0
 
Jason CrawfordConnect With a Mentor Transport NinjaCommented:
Nevermind here it is:

Untitled.png
1
 
servicadAuthor Commented:
Thanks, Jason! I've made these modifications and am currently testing.
0
 
Mal OsborneAlpha GeekCommented:
Atachements are usually UU  or Mime encoded. This allows 8 bit data to be transmitted over systems that only handle 7 bit data, at at the expense of bloating files sizes. Also, sometimes base2 kbytes are used, sometimes base10 Kbytes. Thus, 50MB may be either 50000000 bytes or 52428800. Also, there is some space used by the message body itself, as well as added on headers.

Add all these factors, and it is common for an 8Mb attachment to be bounced by a server configured with a limit at 10Mb.
0
 
timgreen7077Exchange EngineerCommented:
Enough information provided for user to make needed changes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.