Ubuntu System will not boot with external USB Drives attached

Running an Ubuntu 16.04.x LTS system that boots in Legacy HDD mode on SATA0 a 500GB DIsk according to the following test:

Last login: Fri Mar  2 09:02:23 2018
root@saturn:~#  [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
Legacy boot on HDD

I have 2 external USB Hard disks(1TB and 5TB) as well and recently I'm running into a problem that if the USB Drives are powered on/connected the system will not boot. It gives an error that the UUID of the Internal HDD cannot be located. I seem to recall something to fix this in the boot setup but I can't recall or locate details. If I unplug the external drives it works and boots normally.
George R. KasicaLead Systems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
As I understand this ...

The BIOS / UEFI boot is successful.  The linux boot loader (LILO, grub or grub2 as may be) starts up.

The system finds and decompresses the kernel (this can be confirmed by watching the VGA console at startup).

Some things to look at:

a) GRUB is slightly misconfigured.  Check /boot/grub/grub.cfg to confirm that the UUID being passed is the UUID of the boot device.
b) GRUB is slightly misconfigured.  Check /boot/grub/grub.cfg to confirm that grub is passing a UUID, not the LABEL.
c) /etc/fstab is misconfigured.  Check /etc/fstab to confirm that the UUID specified matches the UUID of the boot device.
d) One or more of the USB devices has a boot block on it, and the system is booting from the wrong device.  Disable USB boot in the BIOS.

If you change grub.cfg, don't forget to run update-grub afterward.
0
Travis MartinezSmoke JumperCommented:
No withstanding the questions above and assuming the system is not finding a boot device have you made sure the BIOS isn't set to boot from a USB device target first?
0
George R. KasicaLead Systems AdministratorAuthor Commented:
The system works normally and boots fine with the drives unattached/powered off. It HAD been working with them ON and booting from the internal HDD SATA0 as well until I ran the updates a few days ago on 2/28/18.

apt-get update
apt-get -y dist-upgrade
apt-get -y autoremove

I've done this same update sequence dozens of times followed by a reboot and it has worked just fine. Suddenly I'm facing this issue. I havent touched the BIOS or made any GRUB changes or fstab changes. Boot order in BIOS is CDROM then HDD I've disabled all USB Booting items. I DO see the opening Linux menu though for Ubuntu or Ubuntu Recovery and its failing after it tries either option of any of the 3 kernels I have on the system.

here are blkids of all drives/partitions:
/dev/sda1: UUID="8756-B21D" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="4846c644-e6ad-4866-ae39-45993ab597d7"
/dev/sda2: UUID="52f25ea5-f5c0-4c7e-854e-d6170e371177" TYPE="ext2" PARTUUID="4bec30bc-702b-4301-b871-ad99cebd25e0"
/dev/sda3: UUID="WltXXx-qcoc-7Qwz-CiiL-n03r-yEIp-BldkBE" TYPE="LVM2_member" PARTUUID="0350f2bb-084c-4bc5-862f-3b3b95eb6599"
/dev/mapper/saturn--vg-root: UUID="31e92ee2-56cf-4a10-adf4-22527f214b52" TYPE="ext4"
/dev/mapper/saturn--vg-swap_1: UUID="f67b4149-4aef-41c1-971f-e650df499c80" TYPE="swap"
/dev/sdc1: LABEL="backup" UUID="418c4659-a7f1-4912-88f5-ce3d1ed8a5eb" TYPE="ext4" PARTUUID="000accdb-01"
/dev/sdb1: LABEL="backup1" UUID="84a2d1cf-92e4-44c5-a106-34f66812f329" TYPE="ext4" PARTLABEL="backup1" PARTUUID="d2889858-28a5-4bd2-8385-af54851f5174"

Grub.cfg is attached. It looks normal to me.

Here is fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/saturn--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=52f25ea5-f5c0-4c7e-854e-d6170e371177 /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=8756-B21D  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/saturn--vg-swap_1 none            swap    sw              0       0
0
Dr. KlahnPrincipal Software EngineerCommented:
Try update-grub and see if the situation resolves.  Make a full backup first, because if anything fails you'll be back to booting from a live CD and trying to get it back to the current state.

--------------------------------------------------

As a side note, my own personal policy on dist-upgrade is "Si non confectus, non reficiat."  If there are no problems specifically known to exist, important enough to fix, that would be solved by an upgrade ... leave it alone.

Finally, there are some motherboards that just won't boot when USB devices are attached.  In this case that doesn't sound like the issue; but if there was a recent BIOS update ...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
George R. KasicaLead Systems AdministratorAuthor Commented:
may be a day or 2 to try this out as I need to run a full backup first that takes a bit. Will report results by the end of the weekend. No BIOS updates have been done in the 5 months the machine has been here. Interesting about some systems just not booting. UGH.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Ubuntu

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.