Unusable drive space on fresh RAID OS install/Config Question

Its basically end result - Unusable Drive space.

I have a Dell R610 with 6 bays. I grabbed 6 - 600GB 10k drives to be put into a RAID5. I installed the drives - went into the RAID controller utility - selected all in a RAID 5 - no problem. Put in my Dell Systems Management bootable DVD - selected Server 2008 R2 SP1 and ran it. It finished - asked for the 2008 R2 SP1 media. I put that in and it brought up the Windows install that we all know so well. Everything going great until I got to where to install the OS. I had two choices (Both showing Disk 0 unallocated). One was 2048GB and the other 748GB. Truth be told - I wanted to have 1 entry so I could carve out a 100 or 200GB OS partition and install there. After trying to figure out why it was doing that I gave up and tried to choose the 748 allocation since the data I need to put on this server is a little under 2TB. I was welcomed with an error: Windows is unable to install to the selected location: 0x80300024. Fine. I give up. I'll choose the 2048GB entry and click New and choose 100GB of it to install Windows. I allowed it to complete and when the OS was up - it only showed the 100GB C drive so - I went into Disk Management. I right clicked on the first (1948GB) black uninitialized space and created a simple volume. Good. Next tried the 748. No options are available in the 748 selection.

What I was trying to accomplish was a single VD - RAID 5 config with a 200GB OS and rest to a single Data volume. I tried changing from BIOS to UEFI during the install and after.

I have only needed to change UEFI if I had DISKS 2TB or larger - not that the RAID was over 2TB but it certainly seems coincidental that it broke it apart at 2048 and the rest placed in a separate unallocated line item.

Any ideas on either how to get in the config I am looking for or how to at least utilize the 2048 and the 748?
vpnsol123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andyalderSaggar maker's framemakerCommented:
>I have only needed to change UEFI if I had DISKS 2TB or larger

The logical disk that the OS sees *is* larger than 2TB.

You have to restart, either enabling UEFI and using GPT or creating two "slices" on the array controller so that the first one the OS sees is less than 2TB.
nociSoftware EngineerCommented:
Did you partition with GPT? That will allow bigger volumes. classic partition table is limited to 2TB.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vpnsol123Author Commented:
So the next silly question is how would you partition with GPT? I figured I'd have to start this process over because the end result is an acceptable and that's fine
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

andyalderSaggar maker's framemakerCommented:
Easiest way to start from scratch is to delete the array using the <ctrl R> BIOS utility and create a new one, then you can decide which of the two methods you want to use.
vpnsol123Author Commented:
When I'm creating the raid in the Bios utility control R I don't see any selections for GPT vs. MBR that's where I'm a little confused
nociSoftware EngineerCommented:
You will need to boot with UEFI, you could use a recent linux distro bootable CDROM and use gdisk to partition the drive.
I have no windows systems so i have no idea how to install those.
andyalderSaggar maker's framemakerCommented:
Creating the array in BIOS you can set the size of the first logical disk to be something smaller than 2~TiB for the OS, 150GB for example. Then you can install Windows normally and later use OMSA to create another logical disk for your data later.

If instead you want one huge volume then change to UEFI in the configuration menu during boot (not <ctrl R> disk setup) and delete what volumes you see during Windows installation and take the option to use GPT there during OS install.
vpnsol123Author Commented:
Didn't want to but ended up taking two of the drives and putting in a RAID 1 and the other 4 into a RAID 5 (splitting it up so that the logical drive was less than 2TB)
andyalderSaggar maker's framemakerCommented:
You don't have to do it that way, you can make two logical disks on a single array of disks.
andyalderSaggar maker's framemakerCommented:
They didn't listen to us and did it wrong instead.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Dell

From novice to tech pro — start learning today.