Which setting in Win 10 disables Bridging

On our Win 7 PCs/laptops, we can connect to both corporate wired LAN as well as Wifi (corporate or public or 4G hotspot) at the same time.
However, our Win 10 laptops disallow such bridging ie when connected to LAN cable, the Wifi auto-disabled (with IP address disappeared):
I was told this is not in our GPO setting / hardening nor in any security products that we deploy  but a default Win 10 behavior.

Whereabout is this setting in Win10 ?
sunhuxAsked:
Who is Participating?
 
btanConnect With a Mentor Exec ConsultantCommented:
This article explains how to change the priority of the network connection in Windows 10
http://ecross.mvps.org/howto/change-network-connection-priority-in-windows-10.htm
.. for steps to change the network connection priority in Windows 7
https://support.microsoft.com/en-us/help/2526067
0
 
JohnBusiness Consultant (Owner)Commented:
You may be able to do it , but apparently some laptops prevent this in BIOS.  See if this Microsoft article helps.

https://social.technet.microsoft.com/Forums/en-US/1b2d9ce7-68ad-4fa1-bc2c-eff34b818acf/wifi-and-ethernet-same-time-windows-10?forum=win10itprogeneral
1
 
sunhuxAuthor Commented:
Does Dell E7470 BIOS blocks this bridging feature & if so, where is it?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
sunhuxAuthor Commented:
Those links seem to say they don't want bridging & one link even say there's no option to block bridging in Win10.
However, what I wanted is the opposite ie I wanted bridging
0
 
btanExec ConsultantCommented:
The BIOS setting should be similar for the different dell model. Need to uncheck it otherwise WiFi will be disabled automatically when connected to Wired LAN.

http://www.dell.com/support/article/sg/en/sgdhs1/sln285316/how-to-disable-wireless-when-connected-via-wired-connection-on-latitude-and-precision-mobile-workstations?lang=en
1
 
arnoldCommented:
could you confirm that the wifi and the wired are not actually connected, but the preferred path is through the wired network,
use ipconfig /all to display the adapters and IP information, netstat -rn to display the routing table.

often, the higher preference, lower metric is assigned to the wired interface, while the wifi has a lower/higher metric.

open network and internet settings. see what options you see there.

to John's point, dell as part of power management has the option to disable the wifi when the wired connection is detected:
https://www.dell.com/community/Networking-Internet-Bluetooth/Wireless-is-disabled-when-Ethernet-is-connected/m-p/4529436
1
 
sunhuxAuthor Commented:
Ok  currently in the BIOS, both WLAN & WWLAN are unchecked: I've just checked both:
will test it out tomorrow in office
0
 
JohnBusiness Consultant (Owner)Commented:
Let us know when you have a chance
0
 
sunhuxAuthor Commented:
With both WLAN & WWLAN checked in the BIOS & saved, still no joy:
it still disables bridging on my Dell E7470
0
 
JohnBusiness Consultant (Owner)Commented:
This is something I discourage, but I did find this Microsoft Reference that may help. It may be your machine just cannot do it.

https://social.technet.microsoft.com/Forums/en-US/64f30ed9-cca9-4aed-8c9a-be28e4280076/switching-between-ethernet-and-wifi?forum=win10itpronetworking
0
 
arnoldCommented:
What is the thing that you are trying to achieve, is the laptop your personal or is a member of a domain.
Please check the ipconfig and netstat -rn.
Does the wired connection, grey out the option to activate the wifi?

Check Dell included tools to make sure it is not related to option it could set.
0
 
btanExec ConsultantCommented:
With both WLAN & WWLAN checked in the BIOS & saved, still no joy:
it should be unchecked at the setting to remove the automatic disconnection at BIOS level.

Also at GPO level, refer to the below it has the effect of disabling wifi connections (at software level) when the machine detects it has a LAN connection and can see the domain the computer is a member of. So may need to check this setting is not turned on.

Computer Configuration=> Policies=> Administrative Templates=> Network=> Windows Connection Manager
=> Prohibit connection to non-domain networks when connected to domain authenticated network

Others include a service in the Windows called "Wired AutoConfig" that you need to disable to the wifi adapter so that it does  not get automatically disabled. Do it, and enable the Wi-Fi adapter, it should then not be automatic disabled.
https://www.dell.com/community/Networking-Internet-Bluetooth/Wireless-is-disabled-when-Ethernet-is-connected/td-p/4529436
0
 
sunhuxAuthor Commented:
On Arnold's comment: ipconfig/all shows Wifi is without IP addr when Lan is connected.  

On Btan's to uncheck the 2 Bios options: it was unchecked earlier n yest'day  I checked them n still get the same results.

I will try out the other suggestions n post back.
0
 
sunhuxAuthor Commented:
When LAN cable is connected ipconfig/all  shows the wired LAN port has IP addr but the Wifi port has no IP address anymore.

What do you want to look for in 'netstat -rn' : I don't see any specific Persistent routes being added that makes it
different from our Win 7 laptops (which permits both wired as well as wireless to be connected with IP at the
same time)
0
 
JohnBusiness Consultant (Owner)Commented:
The situation is normal for most machines. It may be your computer will not connect with both cards simultaneously.
0
 
btanExec ConsultantCommented:
Probably to check any GPO setting enforce or setting on the connection profile. Shared that in my previous post.
0
 
sunhuxAuthor Commented:
our AD admins told me they did not set such GPO settings:
in fact they deploy the same GPO on all Win7 & Win10 laptops
& we noted this bridging works on Win7 but not Win 10 laptops.
0
 
btanConnect With a Mentor Exec ConsultantCommented:
I am thinking if the advanced setting for the adapter to allow wifi and ethernet would be make available instead of any disabled state. And also let wireless be in higher order on preference of connection. i.e.: higher priority device = lower number.

https://www.addictivetips.com/windows-tips/give-ethernet-higher-priority-over-wifi-connection-in-windows-10/

Another is Under the "Advanced" tab, can see if there's an option for "Disable on wired connected" or similar language.
If there is, and it’s enabled, disable it. Iread elsewhere there is some setting on "EnableAdaptivity" which was disabled and by changing it to Enable may help.
0
 
btanExec ConsultantCommented:
for author advice
0
 
sunhuxAuthor Commented:
https://www.itechtics.com/5-ways-automatically-turn-off-wifi-ethernet-lan-cable-connected/

Setting Network Priority helps:
can't locate it under "Network" tab, "Configure but further down, the suggestion
just before "WirelessAutoSwitch" section, have to "Microsoft Windows Network"
to the top
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.