an encrypted connection is not available - outlook 2016 to 365

Outlook cannot establish an encrypted connection to 365. "An encrypted connection to your mail server is not available"
On the surface this appears a common issue with many suggestions regard autodiscover online. However let me explain my REAL issue:

I am creating a new mail profile - via control panel, mail, profiles. (an existing profile already exists)
Latest version of office/outlook 2016/365
I can create a new profile to connect to a 365 account on a different tenant.
I can create a profile to connect to a local exchange server.
If I try to connect to problem tenant - I get the encryped error as above.

So I jump on my laptop, and get the same issue.

I remote into a different client and I can connect OK - but it is a different version of outlook. So I guess that may be the issue - although I CAN connect to other 365 tenants.

I remote into a different client that uses the same outlook version - and same problem.
But then..
I create a new USER profile on the PC (it is domain connected so basically I logged in as a different user) - and if I allow outlook to configure the account with its startup login wizard - and it connects perfectly to the problem 365 tenant.

FYI - the exchange connectivity analyser online suggests there are no problems.

I have tried connecting via user@domain.com  and also  user@domain.onmicrosoft.com  exactly the same issue and scenarios.

I am going in circles -
is it my PC?
my outlook version?
the tenant in question?
My current guess is it doesnt like being a second profile - although this poses a problem as the reason for setup is for a mail migration to 365 - every user (40 of them) has a current profile and we need to setup a second profile connected to 365 ready for switchover.  
I dont think this is becuase we still have the old domain pointing to the old mail host.
Basically - old domain - pointing to old host,,  new domainname pointing to 365,  after migration the old domain will be pointed to the 365, but the new domain will be the company default. So I cant see a reason for this to be related.

The 365 tenant isnt new and has been used for dynamics for a few years, and only recently had exchange/365 added to it.

The outlook support and recover tool only madee things worse my trashing any currently existing, working profile.

My only other solution/workaround would be to create a connection to 365 with the first profile, then create a new profile to connect to the old mail server - but this will require resynching email for both accounts and this client has limited bandwidth and several mailboxes over 10gb each - which is why I wanted to commence synching the new 365 profiles in batches and at night before cutover.


Any new. lateral thinking suggestions are welcome.
LVL 20
wolfcamelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wolfcamelAuthor Commented:
I may have stumbled across the solution, which appears to have worked. https://support.microsoft.com/en-gb/help/4046818/zeroconfigexchange-outlook-manually-create-additional-profile  
There is a registry setting that forces outlook to use the wizard for a new profile - but you need to have told it via the registry that you want a new profile but creating a blank profile.

This works - but doesnt explain why I could create a profile via control panel, for other 365 tenants (companys).

ZeroConfigExchange  ! - particularly useful for outlook 2016!

But I would love an easier way as this seems a little difficult to tell remote users!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vasil Michev (MVP)Commented:
The Control panel approach uses a different method, thus you get a different experience, and there are some other issues with it sadly. Dont ask me what the logic behind it is, but overriding the behavior via the reg key usually help,s as you have already discovered. You can also try to use the "suggested" method by going to File -> Account settings -> Change profile, then restart Outlook and follow the steps.
1
wolfcamelAuthor Commented:
No updates, this is still an issue, and the solution I found still remains the only solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.