Unable to scan through Citrix XenApp 6.5

Hello Experts
I am running XenApp 6.5 and have a published application for employees. Part of there job is to scan documents into the application via a USB scanner that is attached to their local PC.

They can scan perfectly locally but the scanner does not function when trying to scan into the published application. It doesn't get listed.

We can also successfully scan into the same application on server locally.

We have already some fixes suggested on Citrix support forums but no luck

Any help on solving this issues will be highly appreciated.
LVL 3
cciedreamerAsked:
Who is Participating?
 
Dirk KotteConnect With a Mentor SECommented:
Do you try ALL steps from this article already?
https://support.citrix.com/article/CTX136395
Helps me some times...

Take a special look to "disable WIA".
Often i have to disable WIA at the local PC for citrix use too.
Try a 32 bit APP. I see problems with 64 Bit versions for same app.
0
 
☠ MASQ ☠Commented:
Scanning through Citrix usually requires Enterprise level hardware for the thin client connection to be handled by the server.
Is your scanner already known to be Citrix compatible?
https://citrixready.citrix.com/category-results.html?f1=printers---scanners&f2=scanners&lang=en_us
0
 
cciedreamerAuthor Commented:
Yes it is compatible

However I discovered that for some users it is detecting and majority of them not
0
 
cciedreamerAuthor Commented:
This URL solved the issue.

May be I had wrong version of DLL.

I copied the file from C:\Windows and solved the issue.
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.