Ssh connection

hi,

My network as 5 Cisco switches and 1 router.

i want to understand how can i configure SSH.

I studing the configuration on Cisco Routers. I  want to be able to access all my router and switches throw ssh.

But i can´t understand how ssh works.

If want from my computer to access all of them. do i need to configure all of them as ssh server.

how do i choose the ip add since my switchs have different vlans and where or which interface will have that ip add?
Bea0227Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam Simon NasserIT Support ProfessionalCommented:
no need to make them SSH server, just allow SSH on them.
check the code i usually use on switches to assign password, ssh and web access,
en
conf t 
enable secret P@$$w0rd
hostname SwitchName
username admin password P@$$w0rd
Interface Vlan 1
IP address 192.168.1.200 255.255.255.0 
Exit
Ip http Secure-server
Ip ssh Version 2
Line vty 0 15
login local 
transport input all
Exit
Exit
Wr

Open in new window

0
Bea0227Author Commented:
About IP address 192.168.1.200 255.255.255.0  is that part of network or is that randow ip just for Ssh connection?
0
Sam Simon NasserIT Support ProfessionalCommented:
its the IP assigned to that switch. i.e. switch 1 is 192.168.1.200 and switch 2 is 192.168.1.201 and so on.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Bea0227Author Commented:
the network 192.1681.0 does it have a default gateway?
Vlan 1 is my native vlan. is that matters?
0
Sam Simon NasserIT Support ProfessionalCommented:
USUALLY IT'S DONE ON vlan 1 WHICH IS THE NATIVE DEFAULT DEFAULT.
the default is usually 192.168.1.1, click start - run and type cmd, in the command box type ipconfig /all ... it will show you your current IP, subnet mask and the default gateway.
0
Bea0227Author Commented:
hi Sam,

i believe you missunderstood me.

i meant to ask if the network that we configure in our vlan has to have a default gateway.

you see all the vlan have a default gateway configured on the router.

so, i want to understand if the ip we use confgire in default gateway need to have a default gateway too.
0
Bea0227Author Commented:
hi Sam,

didn´t work

check my output
hostname sw1

logging console emergencies
enable secret 5 fjhtuj67u76i67
enable password 7 275325356
!
username teste privilege 15 password 7 1494848
no aaa new-model

ip domain-name example.com

crypto pki certificate chain

vlan dot1q tag native


interface Vlan1
 ip address 192.168.60.3 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http secure-server
ip ssh time-out 90
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 access-class 1 in
 exec-timeout 30 0
 privilege level 15
 password 7 014702090A05455D711D1A
 login local
 transport preferred ssh
 transport input telnet ssh
line vty 5 10
 password 7 075B25411F075A5747435F
 login
 transport input ssh
line vty 11 15
 password 7 06520B2C1D404A4B554646
 login

end
0
Bea0227Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for Lia0227's comment #a42489697

for the following reason:

hi Sam,

i went to the router where i configured add a vlan 1 in a subinterface
interface GigabitEthernet0/1.2
 description LAN_SWITCH
 encapsulation dot1Q 1 native
 ip address 192.168.20.1 255.255.255.0

in the switch i allowed vlan 1 in on the trunk
interface TenGigabitEthnet1/0/1
 description LAN_ROUTER
 switchport trunk allowed vlan 1,10,20,30,40,50
 switchport mode trunk

an ip in vlan
interface Vlan1
 ip address 192.168.20.2 255.255.255.0

add gave vty lines basic configuration
line vty 0 4
 password 7 014702090A05455D711D1A
 login local
 transport preferred ssh
 transport input telnet ssh

and voila its working
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sam Simon NasserIT Support ProfessionalCommented:
I think i deserve some point for the guidelines i put
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.