Exchange 2013 sends and receive data from the wrong Echange server.

Exchange Server 2013 sends and receive emails on the wrong mail server .
We do have 4 exchange 2013 Cu19 servers.
These mail servers are located in the Netherlands, China and USA.
We have setup roundrobin dns with 4 different ip adresses on the record outlook.mydomain.com
subnet ordering is working good with the round robin and when checked with a an nslookup the correct Ip adres is given for that subnet.

Problem : outlook is slow, when checking the recource manager and network part of it we see outlook is sending data and receiving data from a total different exchange server other then the exchange server onsite in the given subnetmask order.

So its connecting to the mail server in the Netherlands and somehow its first sending and receiving its data to the server in China or in the USA.
THe mailbox from the user is just in the Netherlands and does not exsist in china nor in the USA?

Is there a way to control this behaviour?
Many Thanks.
ottenshxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
HI ottenshx,
Do you have Exchange server in all the locations?
Did you configure AD sites and services. You have to configure AD Sites and services properly.
DNS round robin is not going to work if you have multiple AD sites with Exchange server on each site.

Please elaborate to understand more.
0
Hasin Ahmed ChoudharyExchange AdministratorCommented:
your Load Balancer(s) and DNS should control which CAS servers your clients connect to.  However, Outlook clients may still connect randomly to different CAS servers to retrieve their Autodiscover settings.

Internal domain joined clients query Active Directory for a Service Connection Point (SCP) to retrieve their Autodiscover settings from.   If the client access servers are not configured for a particular site, the client will choose a client access server at random.

You can ensure the clients connect to the nearest available client access server by configuring the AutodiscoverSiteScope parameter.  Look at the following link for details and the correct syntax

https://technet.microsoft.com/en-us/library/aa998575(v=exchg.141).aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ottenshxAuthor Commented:
Hi , thanks for your reply , at the moment we dont have a load balancer. We use DNS With subnetordering and Round robin.
When we test the round robin and subnetordering its working good. When you are at the site you will receive the DNS record with the correct Cas server , tested with nslookup and then repeated for 20 x nslookup.
I wil go configure the CAS affinity now .
Site and services has a correct setup , Site/ip
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

ottenshxAuthor Commented:
Hi ,

We have setup Cas affinity and reconfigure DNS Subnetmask ordering. at the time we dont see any issues at the moment other then 2 sites that are dropping out of our network scope ip plan. They are very small sites with a couple of users so we did here the quickfix in the host file located in Windows\system32\drivers\etc (host) and added just the ip record to one ip adress. So its not looking in DNS for subnetmask ordering or round robin. A bit dirty but it did the trick for a couple of users. many thanks!
0
ottenshxAuthor Commented:
Thanks to all.
0
ottenshxAuthor Commented:
Looks like all is working . only 2 clients not but seems to be a client problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.