Outlook 2016 not receiving emails from Office 365

Hi, I have configured Office 365 on the local PC with Outlook 2016. Authenticated and went through all OK. It is connected to the Microsoft Exchange but it is not able to receive emails. I can send from outlook no problem. When I login to the OWA I am receiving the emails no problem.

We have also notice that although it says Connected to MS Exchange it is also stuck on Updating inbox for the last 2 days.
Costas GeorgiouNetwork AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
Try to remove outlook from cache mode and see if the emails come through. To remove outlook from cache see the below link
based on your version of outlook.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Costas GeorgiouNetwork AdministratorAuthor Commented:
Thanks for your comment, however we have already tried both options for cached exchange mode and there was no difference.
timgreen7077Exchange EngineerCommented:
If you set up outlook without cache mode it shouldn't say updating inbox. It will only show online with microsoft exchange. If this is working in OWA there seems to be an issue with the outlook profile. I would think removing cache mode would resolve it but since you already tried, i would suggest attempting to open the outlook account on a completely different computer and see if it builds correctly, but uncheck the cache check box when you are creating the new profile on a difference computer.
Costas GeorgiouNetwork AdministratorAuthor Commented:
Thanks for responding Tim. I have configured 8 machines with different profiles and different versions of outlook as well accrss this network. I have also tried both modes across the 8 machines and all are behaving the same way. I will untick the option on 4 and allow it to run overnight. I am suspecting that as I have also imported the existing pst file it may not have completed synchronising, hence the updating inbox message.
timgreen7077Exchange EngineerCommented:
Provide enough info for user to test. User no longer responding, awarding points.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.