Using PFR for Load Balancing.

Using PFR for  Load Balancing.

p

I  have the configuration below. I am supposed to see the load-balancing of the traffic between the paths R3-R4-R6 and R3-R5-R6, but I do not see it happen

R1#
interface Ethernet0/0
 ip address 192.168.123.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.123.3

Open in new window


R2#
interface Ethernet0/0
 ip address 192.168.123.2 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.123.

Open in new window


R3#
interface Ethernet0/0
 ip address 192.168.123.3 255.255.255.0
!
interface Ethernet0/1
 bandwidth 1024
 ip address 192.168.34.3 255.255.255.0
!
interface Ethernet0/2
 bandwidth 64
 ip address 192.168.35.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.35.5
ip route 0.0.0.0 0.0.0.0 192.168.34.4

key chain MY_OER
 key 1
  key-string NETWORKLESSONS

pfr master
 logging
 !
 border 192.168.123.3 key-chain MY_OER
  interface Ethernet0/0 internal
  interface Ethernet0/2 external
  interface Ethernet0/1 external
 !
 learn
  delay

pfr border
 local Ethernet0/0
 master 192.168.123.3 key-chain MY_OER

Open in new window


R4#

interface Ethernet0/0
 ip address 192.168.34.4 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.46.4 255.255.255.0
ip route 6.6.6.0 255.255.255.0 192.168.46.6
ip route 66.66.66.0 255.255.255.0 192.168.46.6
ip route 192.168.123.0 255.255.255.0 192.168.34.3
!

Open in new window



R5#
interface Ethernet0/0
 ip address 192.168.35.5 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.56.5 255.255.255.0
!
ip route 6.6.6.0 255.255.255.0 192.168.56.6
ip route 66.66.66.0 255.255.255.0 192.168.56.6
ip route 192.168.123.0 255.255.255.0 192.168.35.3

Open in new window


R6#
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Loopback1
 ip address 66.66.66.66 255.255.255.255
!         
interface Ethernet0/0
 ip address 192.168.46.6 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.56.6 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.46.4
ip route 0.0.0.0 0.0.0.0 192.168.56.5

Open in new window



from R1 and R2 I can ping loopbacks of R6

R1#ping 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 66.66.66.66
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.66.66.66, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#

Open in new window


R2#ping 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/5 ms
R2#ping 66.66.66.66
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.66.66.66, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/5 ms
R2#

Open in new window



From R1 and R2 I am using ping to generate traffic:

ping 6.6.6.6 repeat 999999999 size 1500

However when I check on R3 with the command: sh pfr master border detail .  it looks like on R3 e0/2 interface Transmits and receive traffic, but e0/1 just receive straffic, it does not transmit
R3#sh pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
192.168.123.3    ACTIVE                UP       01:16:23          0  3.3
 Et0/0           INTERNAL              UP             
 Et0/2           EXTERNAL              UP             
 Et0/1           EXTERNAL              UP             

 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Et0/2           Tx        64          57        64     100 UP                    2
                 Rx                    64        64     100
 Et0/1           Tx      1024         921         0       0 UP                    1
                 Rx                  1024      1024     100
R3#
R3#
R3#

Open in new window



Any Help ?

Thank you
jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atlas_shudderedSr. Network EngineerCommented:
Add ip load-sharing per-packet to R3 - eth 0/1 and 0/2 for a quick and dirty fix or -

Check out this wiki to get into more guts:

http://docwiki.cisco.com/wiki/PfR:Solutions:BasicLoadBalancing
0
jskfanAuthor Commented:
I have added the coomand: ip load-sharing per-packet to R3 - eth 0/1 and e0/2, but it shows like e0/2 is not transmitting any traffic but it is receiving 100%. e0/1 is transmitting 100% and receiving 50 %


R3#sh pfr master border det
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
192.168.123.3    ACTIVE                UP       00:30:07          0  3.3
 Et0/0           INTERNAL              UP             
 Et0/2           EXTERNAL              UP             
 Et0/1           EXTERNAL              UP             

 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Et0/2           Tx        64          57         0       0 UP                    2
                 Rx                    64        64     100
 Et0/1           Tx      1024         921      1024     100 UP                    1
                 Rx                  1024       520      50
R3#

Open in new window

0
jskfanAuthor Commented:
Any update on This ?

Thank you
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

atlas_shudderedSr. Network EngineerCommented:
jskan -

Can you change the bandwidth statements on R3, wr mem, reboot and test again.  Please share:

sh pfr master border detail

Open in new window


after reboot and ping test.

I think that your bandwidth statement may be the source of your woes.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
atlas_shudderedSr. Network EngineerCommented:
Also, on R4 and R5, can you confirm key-chain configuration matches the key on the master?
0
jskfanAuthor Commented:
I have had a chance to Lab it again... I will try to lab it and post  a question if I need to
Thank you for your Help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.