Laptop will not get IP address from DHCP server

I have a Windows 7 laptop on a local domain (abcd.local). The DC and server is a Windows Server 2008 Standard machine.  Approx 50 devices on the network (computers, printers, phones etc.).  Server is the DHCP server.

The laptop is often taken off site, but is back on the local domain usually at least once a week.

Starting this week, the laptop connects to the network but does not get an IP address from the DHCP server.  I've tried both LAN and WIFI, no difference.  I removed/reinstalled the LAN network driver in the laptop.  Also did the various resets (netsh commands etc.).  Disabled the antivirus.  No luck.

I can set a static IP on the laptop and all is good.  This is a problem for offsite however.

How do I troubleshoot this?  When can I look on the server to see if it has a problem with the laptop, for example.

Any help greatly appreciated!
Dave
LVL 1
DaveWWWAsked:
Who is Participating?
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Also try running TCP/IP Reset.

      
Open cmd.exe with Run as Administrator
Then: netsh int ip reset c:\resetlog.txt
Then: ipconfig /flushdns

Restart the computer after running these commands.
0
 
Radhakrishnan RSenior Technical LeadCommented:
Hi

If already not tried, can you open command prompt, ipconfig /release , then 'ipconfig /renew - what's the output you get? based on that we can troubleshoot further.
0
 
Sam Simon NasserConnect With a Mentor IT Support ProfessionalCommented:
does the computer usually take any available ip from the DHCP, or you have a DHCP reservation list? if you have it in reservation list, remove it an d try, if it's not, add it to the reservation list.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
masnrockConnect With a Mentor Commented:
Check your DHCP server. Delete the existing leases, if there are any, for that device's network cards. Then try connecting again.

Also try creating a reservation on your DHCP server, and see if the same issue occurs.
0
 
DaveWWWAuthor Commented:
Thanks everyone.  John's suggestion to run ipconfig /flushdns seemed to do the trick!  I'm not clear on why flushing the dns would fix this issue, since it had no problem reaching the server and all its functions using a static IP, but as long as it works!

Dave
0
 
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help you with this.
0
 
Scott SilvaNetwork AdministratorCommented:
More than likely it was resetting the IP stack that fixed it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.