Error while mounting a restored database

Hello Experts Exchange:
I am using Exchange 2010. Need to restore a mailbox for a user. Restored older database from 2015 with our backups appliance to a new data drive. So for example previous mounted databases are stored on G, this one is on I.  Restore was successful. I see the new restored database in Exchange console. It is showing as dismounted, when i try to mount it i get this below error:                 Any advise would be appreciated. Thank you Advanced.

 --------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'BAB_ExchangeDB1 - Recovery'.

BAB_ExchangeDB1 - Recovery
Failed
Error:
Couldn't mount the database that you specified. Specified database: BAB_ExchangeDB1 - Recovery; Error code: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database 'BAB_ExchangeDB1 - Recovery'. Error: An I/O error occurred while attempting to enumerate log files. Error 0x3 (The system cannot find the path specified) from Windows API 'FindFirstFile'. [Database: BAB_ExchangeDB1 - Recovery, Server: vSRV06.BAB.local].

An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database 'BAB_ExchangeDB1 - Recovery'. Error: An I/O error occurred while attempting to enumerate log files. Error 0x3 (The system cannot find the path specified) from Windows API 'FindFirstFile'. [Database: BAB_ExchangeDB1 - Recovery, Server: vSRV06.bab.local]

An Active Manager operation failed with a transient error. Please retry the operation. Error: An error occurred while preparing to mount database 'BAB_ExchangeDB1 - Recovery'. Error: An I/O error occurred while attempting to enumerate log files. Error 0x3 (The system cannot find the path specified) from Windows API 'FindFirstFile'. [Server: SRV01.bab.local]

An error occurred while preparing to mount database 'BAB_ExchangeDB1 - Recovery'. Error: An I/O error occurred while attempting to enumerate log files. Error 0x3 (The system cannot find the path specified) from Windows API 'FindFirstFile'.

An I/O error occurred while attempting to enumerate log files. Error 0x3 (The system cannot find the path specified) from Windows API 'FindFirstFile'.




--------------------------------------------------------
OK
--------------------------------------------------------
O GChief Technology Officer, Co-FounderAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
Create exchange recovery dB and mount restored dB under that and then restore mailbox
https://blogs.technet.microsoft.com/messaging_and_beyond/2012/05/10/exchange-recovery-storage-group/
1
MaheshArchitectCommented:
The article is self explanatory
Remove existing recovery database, create new recovery database and while creating new dB provide path of restored edb file
Check exchange 2010 link in provided article
0
Valentina PerezExchange ServersCommented:
HI OG,

Could you check the status of database:

Eseutil /mh "database"

It appears in clean shutwdown?

If it appears in dirty shutdown, you will need to repair database.

Regards
Valentina
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
O GChief Technology Officer, Co-FounderAuthor Commented:
Experts,
After restore of the database i ran repair using a third party Exchange tool called Rapid Recovery by Quest. Database was corrupt. I kicked off Aggresive repair which also failed. I then ran Eseutil and fixed the database.

Thank to everyone that responded. Valentina i just saw your message, but you got the right answer! Thank you.
0
O GChief Technology Officer, Co-FounderAuthor Commented:
Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.