Test-WebServicesConnectivity fails due to it using internal host name instead of external

My ManageEngine Exchange Reporter application uses the 'Test-WebServicesConnectivity' command to test my Exchange 2013 server for Client Connectivity Status..  They use the command noted here: https://technet.microsoft.com/en-us/library/aa998328(v=exchg.160).aspx .  The problem is that it's using the internal / local host name instead of the public DNS host name I have noted in the cert..  This results in TLS / SSL issues..  So..  Not only is Exchange 2013 expecting my external host name but the cert bound to it is also using the external host name.  When using the command with external host name is works.. But... By default the 'Test-WebServicesConnectivity' command used the internal name. How can I fix this?
gopher_49Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
See the below article to assist you with setting your name space correctly on your exchange server so that it matches your SSL cert.

https://practical365.com/exchange-server/exchange-server-2016-client-access-namespace-configuration/

It shows how you can set it via Powershell, and the Exchange Admin Center
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gopher_49Author Commented:
I've done all of this...  For some reason ManageEngine doesn't recognize my set internal and external URLs...  And...  Doesn't allow specific URLs when running the Test-WebServicesConnectivity command..  Since all of my URLs come back showing FQDN with matching / valid cert via the Exchange Shell command noted in the link you sent it seems to be an issue on their end...
0
timgreen7077Exchange EngineerCommented:
You should check with manage engine support for that.
0
gopher_49Author Commented:
I did and he is aware of this command not allowing it to specify the URL, however, it will never work using the internal host name for I can only bind one cert at a time to the service?  I could create a multiple SAN with my local CA but that's silly...  I'll just show them the output of this command..  The one showing all internal / external URLs.  I'll reply back on Monday when I hear from them...
0
timgreen7077Exchange EngineerCommented:
Provided answer to user question but issue is with Manage Engine, so user contacted them but never commented any longer on this ticket.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.