SBS-Exchange server not sending email after V2V migration

Exchange 2007 on SBS not sending email to either internal or external recipients, however inbound mail functions.
It's a virtual machine on ESXi 6, (I just did a V2V migration from one esxi host to the other using VMware COnverter); this is the new VM I am operating on.

I ensured that the NIC is on the right IP address and is online, the Virtual NIC on the hypervisor doesn't have any custom configuration.

As per event and error logs:

Microsoft Exchange could not find a certificate that contains the domain name <hostname> in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Smarthost with a FQDN parameter of <hostname>. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.
I did see the certificate it asks for in the Personal certificate store however running the command ends up with it failing:
[PS] C:\Windows\system32>Enable-ExchangeCertificate -Services SMTP

cmdlet Enable-ExchangeCertificate at command pipeline position 1
Supply values for the following parameters:
Thumbprint: <thumbprint>
The certificate with thumbprint <thumbprint> was not found.
    + CategoryInfo          : ObjectNotFound: (:) [Enable-ExchangeCertificate], InvalidOperationException
    + FullyQualifiedErrorId : 78BCD46B,Microsoft.Exchange.Management.SystemConfigurationTasks.EnableExchangeCertificat

I also ensured that mailbox database is mounted and is healthy, the exchange services are all running as well.

Any ideas
365techcaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlanConsultantCommented:
Hi,

To enable the cert from the PS prompt, you need to supply the thumbprint ID such as this example:

Enable-ExchangeCertificate -Thumbprint 1234ab5678c90defa12b3c4567890123456d789e -Services SMTP

Open in new window


That is why you are getting this in the error message you quoted above:

Supply values for the following parameters:
Thumbprint: <thumbprint>

See here for more info:

https://technet.microsoft.com/en-us/library/aa997231(v=exchg.160).aspx


Alan.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
365techcaAuthor Commented:
Hi Alan,

I did provide the actual thumbprint to the command, I just sanitized my posting to you guys.

Looks like exchange is now working after having time to sit overnight. Might've been fixed by its overnight maintenance
0
365techcaAuthor Commented:
Now what I want to know is why it is now working, when it wasn't during the multiple hours I was lookint into it last night.

@Alan, the ceritificate issue is still showing in event log despite mailflow working. So we can disregard that error for now.
0
AlanConsultantCommented:
Hi 365techca,

Please can you re-try the PS command.

The error you copy / pasted in your original post says that no thumbprint was supplied.

Thanks,

Alan.
0
AlanConsultantCommented:
Solution to error posted at least
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.