Paporport 14.5 and Windows 10

I have used Nuance Paperport 14.5 on windows 10 for at least a year now. Something happened the other day and I don't know what but now when I try to use the program itctells,me I seem to be running in the windows xp comparability mode and each time I try to use the program it shuts down. I have uninstalled reinstalled, run registry cleaners, contacted the manufacturer of my scanner (Brother) and Nuance along with a whole host of other things and nothing works. Help!!!
Jerry ChiplinskiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Jerry,

I answered this question for you on Friday when you asked it at my PP14.5/Patch1 article:
How to install the Patch 1 update for PaperPort 14.5

I pointed out there that you have, unfortunately, run afoul of PaperPort's infamous Compatibility Mode problem. I also noted that your question provided me with the incentive to write an article about it:
How to fix: PaperPort appears to be running Windows XP Compatibility Mode, see Technote 6629

That new article has already received one endorsement from a member who said, "...it corrected the error. Good stuff!" Also, prior to writing the article, I know that the method has worked for many, many PaperPort 14.5 users. So, I'm wondering if you posted this question because the method in the new article hasn't worked for you or if you haven't tried it yet — please let me know. Once again, welcome to Experts Exchange! Regards, Joe
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jerry ChiplinskiAuthor Commented:
Hi Joe

I do not know what article I am on but hope this is the combined page. As of today 03/15/2018 I have downloaded and installed the Papaerport patch 1 for 14.5 asyou said, I have also looked at the registry keys listed in the atricle Paperport will not run in Windows 10 as you suggested. None of the registry entries had paprport.exe in them so there was nothing to delete. However in the entry HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows NT\Current Version\AppCompatFlags\Layers everything is there except the \Layres. I do not know why this is missing. I did not delete it. I suppose it is supposed to be there but I have no idea how to get it there. One thing is that before I stumbled on to your article I had Brother tech support connected to my computer to try and solve the problem because they supplied Paperport as their scanning program to us. They did things remotely and  after they could not get Paperporttyo work they told me they had no idea what to do and to use their Contro Center 4 which the users manual says not to use with windows 10 and use Paperport instead.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Jerry,
Yes, this is where I want to continue. This is what Experts Exchange calls a Question. The other two places where you posted are what EE calls an Article. Discussing an issue at either a Question or an Article is fine (or a Video), but pick just one. It doesn't make sense to post the same content three times in three different places, which is what we have now (two Articles and this Question) . So, let's continue here, and only here.

I have several thoughts on your comments above, but I want to start with having you post the dialog box that you are getting when you try to run PaperPort. If you don't know how to do that, this EE article explains it:
How To Embed Screenshots in Posts

Btw, what is your time zone? I'm in US Central Time, and this will be my last post of the night. I'll check back into the thread first thing in my morning. Regards, Joe
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Jerry ChiplinskiAuthor Commented:
Joe for some reason when Paperport is open it will not allow me to take a screen shot. I embeded an image in he document management article. Sorry I just saw the attachment link  on this page.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
> when Paperport is open it will not allow me to take a screen shot

I'm pretty sure that has nothing to do with PaperPort 14.5. How are you taking the screenshot? PrintScreen key? Alt-PrtScrn? Snipping Tool? Greenshot? Something else?

> I embeded an image in he document management article.

Which document management article?

> Sorry I just saw the attachment link on this page.

All Comment boxes here at Experts Exchange have attachment links — Attach File and Attach File from Personal Knowledgebase. They also have the Insert Image icon on the formatting toolbar, which embeds the image inline (as explained in my How To Embed Screenshots in Posts article).

Regards, Joe
0
Jerry ChiplinskiAuthor Commented:
I am going to try this one more time. Paperport will not allow me to take a screenshot when it is open furthermore it will not allow me to do anything except acknowledge the error by clicking ok and the program then shuts down. Anyway I have attached an image of the error. Maybe you can help maybe you can't.  I am eastern standard time.
image001.png
0
Joe Winograd, Fellow&MVEDeveloperCommented:
> Paperport will not allow me to take a screenshot when it is open

As I mentioned above, PaperPort can't stop the PrtScn or Alt-PrtScn key.

> it will not allow me to do anything except acknowledge the error by clicking ok and the program then shuts down

Yes, that's the well-known PaperPort 14.5 "compatibility mode" problem.

> Anyway I have attached an image of the error.

So you are able to take a screenshot! Please compare that image to the one at the top of this EE article:
How to fix: PaperPort appears to be running Windows XP Compatibility Mode, see Technote 6629

The images are identical! I'm very confident that the method in my article will solve your problem. The quick summary is to find these keys in the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Then delete any entry on the right side with PaprPort.exe in it. All of the caveats about modifying the registry apply. If you don't know how to do it, find someone who does.

This will very likely fix the problem — it has for many PaperPort users. Regards, Joe
0
Jerry ChiplinskiAuthor Commented:
Joe once again that does not fix the problem. I have done everything that you have suggested and followed all instructions to a tee. Apparently the only service that you offer is one that repeats what can be found on the software developers site. Which by the way I have gone to and done everything you mentioned numerous times before I stumbled upon your site. You should already have known this because I mentioned that in the very beginning. If you come up with any solutions on your own that do not repeat what the developer tells me to do please let me know.
Thanks
Jerry
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Jerry,
Please post screenshots of these two registry keys:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Mine look like this:

HKCU-AppCompatFlags-LayersHKLM-AppCompatFlags-Layers
I'd like to see what both of yours have in them. Be sure to capture the full window, as shown in my screenshots above. Thanks, Joe
0
jjgappCommented:
Your “clean up the LAYERS key” solution to resolving the PaperPort compatibility problem has been around for some time and I’ve been using it when I have the problem with PaperPort 14.0 with Windows 10.   Your recent update of this solution should be welcomed by the many PP users that run into this compatibility problem.

The good news is that the solution works.  The bad news is that, at least for some of us, it is not a permanent solution.  Every few months my PP program won’t load and I have to go into the register and delete the PP entries in the “layers” keys.

It just amazes me that the people at Nuance are so uncaring and/or lazy that they have not seen fit to resolve this issue once and for all.  The compatibility problem is, of course, not the only PP problem that Nuance seemingly choses to ignore.

If I were more computer savvy I’d design a batch file to make the register changes that fix this issue and put it on the street.  Unfortunately, I am not.  Maybe someone……?

But good on you for updating the info on the PP compatibility issue.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi jjgapp,
Thanks for jumping in...that's great feedback! A few comments on your comments:

> PaperPort 14.0 with Windows 10

I don't know if it will make the Layers problem stop happening for you, but you may want to upgrade to PP14.5. My EE article explains how to get it at no charge for folks with earlier PP14 versions:

PaperPort 14 - Free Upgrade to Version 14.5

After that, I recommend installing Patch 1, since PP14.5/Patch1 is the only W10-compliant version of PaperPort. Another one of my EE article shows how to get it, also at no charge:

How to install the Patch 1 update for PaperPort 14.5

Since you're on W10, you may find another one of my EE articles to be helpful:

PaperPort 14 in Windows 10 - A First Look

> Your recent update of this solution should be welcomed by the many PP users that run into this compatibility problem.

Thanks for the compliment — much appreciated! I wrote this EE article about it:

How to fix: PaperPort appears to be running Windows XP Compatibility Mode, see Technote 6629

Since you are clearly knowledgeable about the problem, I'd be grateful if you read the article and let me know if there's anything you would add or change based on your experience with the issue...TIA!

> Every few months my PP program won’t load and I have to go into the register and delete the PP entries in the “layers” keys.

I've never seen it occur that often, but most PaperPort usage that I'm involved with is on W7. I wonder if the problem is more prevalent on W10.

> It just amazes me that the people at Nuance are so uncaring and/or lazy that they have not seen fit to resolve this issue once and for all. The compatibility problem is, of course, not the only PP problem that Nuance seemingly choses to ignore.

I hear you on that. Lots of similar complaints from many PaperPort users.

> If I were more computer savvy I’d design a batch file to make the register changes that fix this issue and put it on the street. Unfortunately, I am not. Maybe someone……?

Interesting idea...I'll think about it.

> But good on you for updating the info on the PP compatibility issue.

Thanks!

Btw, while working on this comment, I realize that I've been overlooking a third registry key that may also have the Layers problem:

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows NT\Current Version\AppCompatFlags\Layers

I just updated my article with that third key.

N.B. for Jerry: Note the addition of the third registry key that may have AppCompatFlags\Layers.

Regards, Joe
0
jjgappCommented:
Thanks for your comments!  I didn't make it clear that I'm using PP 14.5 with Patch 1.  Nuance just perpetuates the problem that's been around for years,
John
0
Joe Winograd, Fellow&MVEDeveloperCommented:
> I'm using PP 14.5 with Patch 1.

OK, good to know! When I saw "PaperPort 14.0 with Windows 10" in your post, it raised a red flag.

> problem that's been around for years

Yep, at least eight years that I'm aware of...could be more.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
The author never came back to post his screenshots of the registry keys, so I can't go any further with the troubleshooting. I realize that he says the problem is not solved yet, but I think that other EE members with the same problem will be well-served to find this question in the PAQ. As noted by one comment in this thread and two comments at my article, the solution worked for them...and I can state for a fact that it has worked for many PaperPort users. I selected helpful posts and split the points in what I think is a fair distribution.
0
Jerry ChiplinskiAuthor Commented:
Hi Joe

I'm sorry it took so long to get back to this. I still have not solved the problem I am having with Paperport 14.5 and the compatibility error. I have done all you suggested with no difference being made. Here are the three screen shots of the registry you wanted me to take.registry screen shotregistry screen shotregistry screen shotThanks Joe
1
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Jerry,
Thanks for coming back to the thread and posting your screenshots. Unfortunately, there's nothing in there that gives me a clue to the problem. Your situation is the most problematic one I've ever seen on this issue and I've given you every trick in my arsenal on it. I reached out to my contacts at Nuance and will post back here if they have some new ideas. Regards, Joe
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Document Management

From novice to tech pro — start learning today.