SharePoint AutoSPIinstaller fails with error about "feature not installed"

Long question for you all.

I am using AutoSPInstaller to install and configure a multi-server farm for a customer (SharePoint 2013 Enterprise). In my DEV environment it works perfectly (albeit with some slightly different names).

In the live environment, it gets as far as creating the first Site Collection in the first Web Application, and it errors out - "sharepoint autospinstaller feature with id c85e5759-f323-4efb-b548-443d2216efb5 is not installed in this farm". When I checked the Central Admin site, it was stopped in IIS - when I started it, I was able to access the site - and I am unable to create the Site Collection via the GUI - it returns the same error.

The customer does have various permissions locked down in the environment - this may have something to do with it, or it could be an issue with the SQL server.

Before I try and get the other teams to investigate their side of things, is there anything anyone can suggest that I can check to help me rule out any issues with the SharePoint servers and AutoSPInstaller?

cheers
LVL 3
Derek SouterITO Svc Delivery Cons IIIAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Derek SouterITO Svc Delivery Cons IIIAuthor Commented:
I was able to resolve it - for some strange reason, the Workflows feature had not been installed - even though the files were there.  i ran teh install-spfeatures -allexistingfeatures command, and re-ran the setup - everything is working fine now (so far)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Derek SouterITO Svc Delivery Cons IIIAuthor Commented:
feature had not been installed - for some weird reason
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.