Areca RAID Enclosure dismounts itself.

I have a Norco RPC-4216 server case (I know cheap as you can get) but I have an Areca RAID Card in it and the RAID Card reports every once in a while that an entire enclosure is getting dismounted. This is causing database corruption and the server ceases to run reliably and reboots until I recreate the database
See attached Picture.

Do you think this could be back plane related. I have replaced the RAID card with a brand new one even a different model Areca Card (updated card) and it seems to be the same problem I had with the first.

Any help is greatly appreciated.

Thanks.
Enclosure-Removed.png
LVL 2
beatifiedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
You seem to have multiple drives in enclosure 2 that are being "removed" and reports that the array is "degraded".  I think you need to replace some failing drives.
1
masnrockCommented:
Most likely the backplane. I had another brand of RAID enclosure, and it was a nightmare. Every few months I had to replace it. Had like 3 replacements under warranty, and it was always the exact same issue. Bought a second as a spare for a while, same issues. Eventually just stopped using the enclosure entirely.

Edit: Follow the advice from Davis first. Of you still get issue of disconnection after the drives have been replaced and the array has been rebuilt, then look at the backplane.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
The problem is clearly a conflict between the RAID controller and the backplane.

1: Make sure the compatibility lists for both list each other
2: Update the firmware on the backplane
3: Update the firmware on the RAID controller
4: Update the firmware on the Expander

Given the error series in the image I suspect there is an expander in place? Meaning, the RAID card has either 4 or 8 ports with more drives than ports thus the need for an expander.

Many backplanes, especially "inexpensive" ones, do not support SES leaving the RAID controller blind especially in a scenario where there is an intermediary like an expander.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

beatifiedAuthor Commented:
I've attacted a csv of the entire log

@Davis It may be useful to understand that I only have one enclosure and I only have 8 drives all of which are showing "removed" not "failed". These are the two terms used on Areca Cards. If you look you will see that any failure is due to a drive or multiple drives being "removed" even though physically they are not being removed. And infact all the drives are being "removed" and "added" within 20 seconds or less. Do you still feel I am having a drive failure? I don't see it personally. This is from the manual "Event - Device Inserted, Level - Warning, Meaning - HDD inserted" "Event - Device Removed, Level - Warning, Meaning - HDD removed" "Event - Device Failed, Level - Urgent, Meaning - HDD failure"

@Masnrock and @Philip So I was thinking essentially the same thing but failure not incompatibilty. The real problem is I had a different RAID card in there before and I didn't have any of these problems for years and I mean at least 2 or 3 years. I had an occasional failed drive and replaced it with no issues at all but nothing more. Then a few weeks ago I started getting (from what I remember) the same exact type of errors on my old RAID Card. Thinking my RAID card had failed I replaced it (ARC-1680IX-16-4G) with my current ARC-1883ix24 Card. But the problem seems to persist. I can install my old RAID Card and get the log off of it and see if it is similar. I guess my thought is backplane failure not incompatibility since it worked for years.

I will try to pull the log off of the old controller in the next day or so.
RAID-Controller-Log.csv
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
If that's the case then I concur. The backplane is the culprit.

I suggest seeing if there is a firmware update or at least a firmware file that can be flashed to the backplane to see if it settles down.
0
beatifiedAuthor Commented:
@Philip Elder like I said I am going to try to get the log off of the old RAID card and see if its similar issues. If so I think I'm just going to get a supermicro case and be done with the garbage case. supermicros are just so loud.
0
masnrockCommented:
I was thinking failure all along. As Philip pointed out, you should try making sure that the firmware is up to date. The enclosure I mentioned having the backplane issues was doing exactly what you were describing. The obvious side was the drives suddenly not being there. The moment I moved the drives into a new enclosure, no problem (well, until that backplane would fail).
0
beatifiedAuthor Commented:
@masnrock That's promising to hear. BTW the backplane in my case seems to be 4 separate backplanes as seen in the attached picture. I am only using the top two connections as I have 8 drives not the full 16 that are available. In the short term I am simply going to move the drives to the bottom 2 backplanes.

Do you see it likely that I am disconnected and reconnected from 2 backplanes at pretty much exactly the same time? Or at least within a second of each other.

Were you seeing this type of issues as well or was it all on a single backplane?
Norco_RPC-4216_06.jpg
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
With the LSI/Intel RAID controllers we're able to move drives around without worrying too much about the RAID configuration which is stored on the drives themselves.

I'm not sure about the Areca.
0
beatifiedAuthor Commented:
@Philip Yep I already switched them around with no problems so far. I dont think this is a solution but might give me a little more confidence that I found the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.