Server 2016 w/ Exchange 2016 100% CPU on MAPIFrontEndAppPool & MapiMailboxAppPool is this a bug?

Anyone run across this issue

We have a new environment with Server 2016 fully patched .net 4.6.2 & Exchange 2016 CU8 (but issue occurred on CU6 as well). I am seeing 90%+ cpu load on a VM with 8 CPUs, 24 GB of Ram. This environment only has 60 users so the load shouldnt be that high. They are all in online mode as they work out of Citrix. The 2 highest process at about 60% are the MAPIFrontEndAppPool & MapiMailboxAppPool

We have similar and larger environments with the difference between Server 2012 R2 and Exchange 2016 without any issues. Has anyone read about any issues with Server 2016 & Exchange 2016?

I have an open case with Microsoft but wanted to reach out and see if anyone has seen this in their environments.
iVenture_SolutionsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
90% CPU load is not normal. I will ask, if all VM tools are updated and resources are not dynamically shared. Next, I assume you have enough resource on your VM server itself. Normally, I recommend 20% threshold.

As you already have MS case, post the findings, if you are unable to get any solution from them. I might also check antivirus exclusion to make sure, it is not scanning bin and db files.
0
AmitIT ArchitectCommented:
Any update?
0
iVenture_SolutionsAuthor Commented:
So we figured it out. Turns out it was a 3rd party application from Worldox(Document Management) but not the base app it was an extra module called Worldox Folders or Drop Folders and when your outlook clients are in online mode (Citrix env) then it causes a lot of mapi communication. We disabled this function and now its back to normal levels so less than 10% cpu usage on IIS services/app pools vs 90%+ with it enabled.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AmitIT ArchitectCommented:
Thanks for the update.
0
iVenture_SolutionsAuthor Commented:
Resolved the issue with our 3rd party application.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.