Getting an error when logging into IFD

I finished configuring ADFS and Claims Based Authentication for CRM 2016 but I am getting an error when I try to connect.  The login page comes up but I am getting the error below:

A WS-Trust endpoint that was configured could not be opened.
Additional Data
Address: https://wwmh.net/adfs/services/trust/2005/windowstransport 
Mode:    WindowsTransport
Error:
MSIS0006: A Service Principal Name is not registered for the AD FS service account.


I could use some assistance in where to start to troubleshoot this error.  

Note: during ADFS setup, I ran the setspn command below and it told me that the spn already existed, so I just continued on.
(setspn -a http/sts1.wwmh.net wwmh\CRMTest )
 


This appears to be causing the problem:

Note: during ADFS setup, I ran the setspn command below and it told me that the spn already existed, so I just continued on.
(setspn -a http/sts1.wwmh.net wwmh\CRMTest )

I received the following information from the System Admin:

You'll need a different one. If I change the current sts1 record it will break production crm.
Can we do adfs.wwmh.net?

My question:
How do I change the spn to adfs.wwmh.net?  I entered the following into a cmd prompt and it seemed to add the spn but sts1 still comes up when I browse the IFD externally.

(setspn -a http/adfs.wwmh.net wwmh\CRMTest
LVL 1
apollo7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

apollo7Author Commented:
This appears to be causing the problem:

Note: during ADFS setup, I ran the setspn command below and it told me that the spn already existed, so I just continued on.
(setspn -a http/sts1.wwmh.net wwmh\CRMTest )

I received the following information from the System Admin:

You'll need a different one. If I change the current sts1 record it will break production crm.
Can we do adfs.wwmh.net?

My question:
How do I change the spn to adfs.wwmh.net?  I entered the following into a cmd prompt and it seemed to add the spn but sts1 still comes up when I browse the IFD externally.

(setspn -a http/adfs.wwmh.net wwmh\CRMTest )
0
apollo7Author Commented:
We are limiting testing to the inside. The outside routing is not enabled, all ports are bound to production servers to route from the outside of the network…
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
apollo7Author Commented:
Problem solved
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.