How do I fix the voice command for my hands free device in my car?

I have a Samsung Galaxy S7 and I use Android Auto to connect to my car.  I recently lost the ability to use the voice command "Ok Google". I can still prompt it if I touch the mic on my car dashboard and then voice command whatever I want it to do..

Note: That this has worked before with my current set up. It may of stopped working after a recent phone update, but I can't be sure.

My settings in Android Auto are on to allow voice command. Are there any other settings that might be causing this?

What's the best way to troubleshoot?
LVL 3
Nichole LaRueMarketing OperationsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lucas BishopClick TrackerCommented:
Have you tried un-re-installing the Android Auto app?
0
Nichole LaRueMarketing OperationsAuthor Commented:
I did uninstall and reinstall the app. I walked through all of the enabling/allow access to flows and it still will not allow me to audibly prompt with "Ok Google". I still have to physically push the mic icon to use voice command.
0
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
The same thing happened to me and I just ignored it.  I did just figure it out though.

Hold down the home button until you get the Google Assistant. Click on the blue icon on the top right, then the verticle ellipsis menu when you see, "Explore" and "Your Stuff".  Go to Settings > Phone.  Turn on "Get hands-free help with Voice Match.  I turned on "OK Google" detection and "Unlock with Voice Match".
1
Nichole LaRueMarketing OperationsAuthor Commented:
Thanks everyone for chiming in. I had tried various settings and reinstalling the app to no avail. Then I was unable to try Scott's suggestion because the phone ran some app updates and suddenly the voice command was working again. So, although all the troubleshooting suggestions were very helpful I can't confirm what the actual issue was other than the app itself.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nichole LaRueMarketing OperationsAuthor Commented:
The phone fixed itself with an app update.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphone Programming

From novice to tech pro — start learning today.