my local PC is talking to the DNS of my ISP instead of my local DNS within the domain

Dear experts,

I have a Window 2012 R2 server running DNS, DHCP, and AD DS and a sonicwall firewall. For some reason that my DNS server is not working. When I look at my network connection from Window 7, I can see that IPv4 Default Gateway is 192.168.1.1, IPv4 DHCP server is on 192.168.1.30 but IPv DNS server is on 68.x.x.x It is not pointing to my DNS which should be the same as the DHCP server (192.168.1.30). I am not sure what went wrong as in if there is a mis-configuration in sonicwall firewall/router or the DNS server at 192.168.1.30.

I can see my client PC is not talking to the local DNS server 192.168.1.30 but instead on 68.x.x.x my ISP. Is there a way to configure in order to ensure my client PC will ask my local DNS first if no information can be found then forward to the DNS of my ISP and so forth?  I have set my TCP/IPv4 to Obtain an IP address automatically and Obtain DNS server address automatically. Is there a way to set obtain IP and DNS server automatically rather than set those to static?
Kinderly WadeprogrammerAsked:
Who is Participating?
 
yo_beeConnect With a Mentor Director of Information TechnologyCommented:
Check you DHCP | Server Option | DNS is set  to you ISP?  

Capture.PNG
0
 
Kinderly WadeprogrammerAuthor Commented:
Hi yo_bee!

Thanks. I will do the configuration soon. May I ask you for your 015 DNS Domain Name, what value should I input? Thanks
0
 
Blue Street TechConnect With a Mentor Last KnightCommented:
Hi Kinderly,

Your 015 DNS Domain Name should reflect your local Windows domain.
1
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
yo_beeDirector of Information TechnologyCommented:
The more important item is 006.  Was that set to anything? Pleas note that the Server Option also resides in each one of the SCOPES.
It may have one setting at the top level, but also have a setting in the SCOPE level.  I would check both areas.  You are 100% sure that your SonicWALL is not dishing out IP's?
0
 
Kinderly WadeprogrammerAuthor Commented:
Hi Blue and yo_bee,

I've tried it and added to the server option in my DHCP. It doesn't seem to work. I restarted my PC and log back in and I am still having IPv4 DNS set to 68.x.x.x. Do I need to restart my DNS server as well or are there possible steps that I missed? Thanks =). The server option was all blank so I added all those back in.
0
 
Kinderly WadeprogrammerAuthor Commented:
I am browsing the TCP/IP setting I can see there are 3 tabs in Window 7. They are:
1. IP Settings
2. DNS
3. WINS

Do I need to configure the DNS one as well or I can leave that field alone which configuration on the server side should be sufficient enough?
0
 
yo_beeDirector of Information TechnologyCommented:
Can you post some screenshots showing us what you are seeing?
Is this a single machine or is it every machine on your network.
Is it set in the computers Adapter properties vs allowing DHCP to handle it?
It  is getting this from some source.
0
 
yo_beeDirector of Information TechnologyCommented:
You should not have to touch those, but if there is ip-address for DNS? Are you seeing this 68.x.x.x number anywhere in the setting?
0
 
Kinderly WadeprogrammerAuthor Commented:
sure no problem. Let me get some screenshots. Btw my IP is 10.1.8.x sorry. I thought it starts out with 192.168.x.x (used to the 192.x.x. one)

Here is my client image:

 

Here is my server image:

here is my server
hope these images help out. I've restarted my client PC but still grabbing the IP from ISP
0
 
yo_beeDirector of Information TechnologyCommented:
what about the screenshots of your IPv4 Properties.  They could be hard set there.

Have you checked the 10.1.8.0 scope Server Option.  There is one there as well.
0
 
Kinderly WadeprogrammerAuthor Commented:
my IPv4:

IP.png
IP4.png
0
 
yo_beeDirector of Information TechnologyCommented:
Not that.

This is what I was referring to.
 capture.png
0
 
Kinderly WadeprogrammerAuthor Commented:
Thanks guys! you guys are the best!
0
 
yo_beeDirector of Information TechnologyCommented:
what was the issue?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.