Wireless Network Adapter assigns incorrect address

Hi Guys,

My notebook's wireless adapter has been messing around.
When I plug a network cable into my machine, my notebook identifies the network immediately and assigns an IP address.

With wireless it is a different story,
It normally assigns a 169. address and I have to disable / re-enable the adapter to fix the connection.
It doesn't matter whether I am connecting to a hot-spot, my own wireless network or my 3g stick.

I am using Windows 10, but happened with previous O/S also, this is also my second notebook with the same issue.
I suspect the issue is probably related to some software that I am running on my machine.

I created a shortcut to disable / re-enable my wireless NIC and this seems to work as a "temporary" solution, but I would like to fix it permanently!

Any ideas will be appreciated ...
Rupert EghardtProgrammerAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
Run TCP/IP Reset

Open cmd.exe with Run as Administrator
Then: netsh int ip reset c:\resetlog.txt
Then: ipconfig /flushdns

Restart after all the above and test.
0
 
Omar SoudaniSystem Support EngineerCommented:
Try  > adapter settings and then into configure on the "Connect using" option. This brings up the wireless network device settings. From there you can choose power management and deselect "allow the computer to turn off this device to save power"
0
 
Rupert EghardtProgrammerAuthor Commented:
Thank you, I've deselected the power management option for the NIC, (was turned on)
Let me test switching between WiFi connections ...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
nociSoftware EngineerCommented:
169.. address is an apipa address. which windows uses after  dhcp fails.
So latency on wireless might be too long to get an address ..
0
 
ITguy565Commented:
I am going to take another approach and assume that this may not be occurring on just this workstation.. Are you having this issue on any other boxes? Another possible cause could be that you are either out of DHCP addresses or the DHCP server is stopped or in a faulted state.
0
 
Rupert EghardtProgrammerAuthor Commented:
Thanks Guys,

I switched to my 3g modem after removing power management from the wireless NIC.  My notebook connected to the 3g modem and showed connected, but the IP stayed the same as if on my home Wifi network.  No internet.
I had to disable / re-enable the NIC to restore internet and notebook picked 3g modem IP range.

I am now trying the Netsh option and report back soon ...
0
 
Rupert EghardtProgrammerAuthor Commented:
Thanks John,

I think you might have hit the nail on the head ...

I did what you suggested:

Open cmd.exe with Run as Administrator
Then: netsh int ip reset c:\resetlog.txt
Then: ipconfig /flushdns

Did a restart, and it seems to be working!
How wonderful not to disable / re-enable the NIC every time.

I do a couple of more tests and close the question.
Thank you!
1
 
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and that is how I solve these things.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.