Active Directory cannot start

I had this question after viewing Active Directory Broken.

I had server working fine running server 2012.  Its sole purpose was to handle incoming files via FTP.  I installed SmarterMail 16 on it and configured IIS & the Windows firewall and all was fine.  Everything worked or so I thought.  A couple of hours later I tried to connect via a VPN to the server and received erroneous errors about the login authentication methods.  Upon logging into the server directly I find Active Directory is no longer running.  Directory Schema is unavailable.  An invalid directory pathname was passed.  Inappropriate authentication.  I cannot get into any facet of Active Directory.  I cannot get into Group Policy.  I ran Dcdiag and LDAP returned error 52 unable to browse attributes.  Any recommendations at this point would be greatly appreciated.
AndyMTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph HornseyPresident and JanitorCommented:
A couple of questions:

1. Is that server a domain controller?
2. Did you upgrade the OS?
3. Have you tried disabling the firewall?
4. Does SmarterMail use LDAP for authentication or have its own directory service?

I'm not sure any of those matter, but it's off the top of my head.
0
AndyMTAuthor Commented:
1.  Yes the server is a domain controller.  Stand alone setup.
2.  The OS was a fresh install of Server 2012 a couple years back.  Kept up on the updates but that is all.
3.  I tried disabling the firewall already as that was one thing I edited when installing SmarterMail.
4.  I believe SmarterMail has its own directory service.  It is still functional so it must not be accessing AD.
0
Joseph HornseyPresident and JanitorCommented:
Yeah, but if it's using LDAP and taking the port, then AD won't work correctly.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Joseph HornseyPresident and JanitorCommented:
If it won't cripple your organization, the first thing I'd do is remove SmarterMail and see what happens.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AndyMTAuthor Commented:
That is a logical step.  I will give it a shot right now.  Nothing to lose at this point.  Already pointed mail back to the original server.
0
AndyMTAuthor Commented:
Well my friend you hit the nail on the head.  Uninstalled SmarterMail and it appears all is back as it was.  If you would explain to me "but if it's using LDAP and taking the port, then AD won't work correctly" so can take the issue to SmarterMail support.
0
Joseph HornseyPresident and JanitorCommented:
Well, Active Directory is your directory service for authenticating computers and users in your domain.  The protocol used for querying Active Directory is LDAP which uses TCP 389 as its port.

If SmarterMail is also using an LDAP-based directory for authentication, now you have a conflict.  Two different services using the same port for listening on the network.

Since LDAP is no longer available for Active Directory to use, it basically is nonfunctional at that point.
0
Joseph HornseyPresident and JanitorCommented:
See if you can configure SmarterMail to use AD for its authentication instead of its own.  I would think it can do that.

Did you, by chance, turn on some sort of Exchange emulation?
0
AndyMTAuthor Commented:
Thank you.  Explains it perfectly.
0
Joseph HornseyPresident and JanitorCommented:
My pleasure!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.