• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 59
  • Last Modified:

Access 2003 mdb won't open linked tables after local LAN DNS server switch

Access 2003 mdb with a SQL 2014 backend. We recently changed DNS servers on our LAN to a new box with a new name and IP address, and now the ODBC linked tables to SQL take forever to open. Is there something in an mdb that remembers it's LAN DNS server? I already tried relinking a few tables with the linked table manager, no difference. I do know, however, that the ODBC DSN is fine because I created a test mdb and added a few linked tables from the same SQL backend, and they open lightning fast. It's just something about this existing mdb that now won't open tables in a tolerable time.
0
QMBB
Asked:
QMBB
4 Solutions
 
PatHartmanCommented:
I'm not sure what Access caches.  However if linking new tables using the same DSN results in no problem, I would simply delete all the linked tables and start again.
0
 
QMBBAuthor Commented:
Thanks. Hey, I am just now noticing that even local tables, not linked, take the same forever to open. So, it's not just linked tables.

wth???
0
 
QMBBAuthor Commented:
and, linked tables using a different DSN (an ODBC tour our MySQL web server offsite) also take forever to open. These are all tables with hardly any records, btw.

So, it's an issue opening ANY table no matter if it's linked or not.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
QMBBAuthor Commented:
and, it's just this ONE mdb. I have a few others that have some of the exact same linked tables to SQL and they open just fine.

This mdb has been around since 2003, and the DNS server that has been retired did exist when this mdb was created, if that makes a difference, but I don't see how.

There are about 6 dll's and a couple .ocx's that I had to register with Windows when i installed this mdb back in 2003 , but.... maybe I need to re-register them?
0
 
Gustav BrockCIOCommented:
Create a new 2003 mdb file, attach the tables, and see if you can open and read these at normal speed.
If so, reference the dlls and ocxs. If tables still open rapidly, import all objects from the old 2003 mdb.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
Check and see if you have any mapped printers or drives that are not available.   If so, disconnect them.

  These will slow down the process that Windows goes through when dealing with network connections.

Jim.
0
 
John TsioumprisSoftware & Systems EngineerCommented:
Check if your settings in the workstations NIC point to the new DNS or the continue to use the old one..
0
 
QMBBAuthor Commented:
John, good point, but yes the workstations were already pointing to the new DNS server. Gustav's solution did the trick.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now