Trouble connecting to Oracle Database with Crystal Reports 2016 on Windows 7 Pro 64bit Machin'

Crystal Reports 2016 not connecting to an Oracle DB on the same machine that another similar Tool Tableau Desktop (10.5) the Dashboard Design tool can connect. Errors include "Not implemented" when using the ODBC Oracle in instantclient_11_2 which clearly works for other connecting tools. I have also tried to connect through OLE DB (ADO) as well as having created my own connection through ODBC.

The machine which has CR2016 on it is Windows 7 Pro 64 bit. The ODBC datasource does connect to odbcad32.exe and that is where the Tableau license connects to the data. Not sure if that is the culprit. I am currently searching for odbcad64.exe (thinking that might be the problem...but not sure)  but not found yet. I am not sure it is needed?

Also I can make my own connection to the datasource with my credentials which I use the local ODBC admin tool. I did notice that when I connect with Tableau the tool launches this screen:
The window I get when connection to Oracle Server is made. I have all credentials for it.
But when I launch Crystal Reports I get the common database expert. When I go to the places I think I should be connecting to I do not get the same interface as mentioned above with ODBC OLEDB and others.

This is what most of the errors are when connecting through to any of the Oracle connections.Not sure what would cause this connection to be so difficult to attain since one product on the same machine can but not the other.??? Any help on this is greatly appreciated.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
I believe Crystal Reports is 32Bit.  You will need the 32Bit Oracle OLEDB drivers.

Starting with 12c they are now part of: Oracle Data Access Components

I prefer the XCopy version:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
What is interesting is that when you go on the machine it seems that either Crystal is pointing to its own ODBC connector because the driver which was installed on we assume is the ODBC 32bit under Windows\system32\ odbcad32.exe shows the Oracle in instantclient_11_2  driver which we installed. When you launch Crystal Reports 2016 and launch the database expert the driver does not show up anywhere. Meaning the Oracle in Instantclient_11_2 is not available to install as an instance.

So I am baffled as to what is wrong with the picture. It is as if Crystal Reports is loading its own ODBC connection and it acts like you have to reinstall it unfortunately it is nowhere to be found to install in the same way it was on the machine initially with odbcad32 under System32 folder.

My initial thought is that I need to use the odbcad32.exe under the Windows\SYSWOW64\ which I am certain is the 64(bit version. Maybe I need to to download a different version of the Oracle driver for 64(bit) and attempt to install. Is that why the odbcad32.exe under \system32\ shows up and not on the other \SYSWOW64\  ?
 I am not sure what to do here because I am confused as to whether there are more than just the two odbcad32.exe's are there more when Crystal creates a new install? Do you have to have administrator level permissions to add an Oracle driver to it?

Also since I have the Oracle in Instanceclient_11_2 I does it matter which one I use on the oracle site here as long as it is 64 bit?
OracleListOfDrivers.pngOr is it okay to use the version 12 with no issues as mentioned "Netminder"...?
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
That was it installed Xcopy and that worked. Thank you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.