Unable to RDP into the Device, checked and found out Windows Firewall is Missing

Hello Everyone,

Been having problems bringing up Windows Firewall Service back into a Windows 10 Pro 64bit computer.

I have attached the list of services on this computer in question but Windows Firewall is not listed there.

Things done so far:

Disabled the GPO that might be causing this problem.

Run the following command lines:
          1. netsh advfirewall reset
          2. net start mpsdrv
          3. net start bfe
          4. net start mpssvc
          5. regsvr32 firewallapi.dll

Rebooted computer and still nothing.

I also tried copying MspSvc.reg file from an identical - known working computer and it didn't worked either.

Made sure all Windows Update are installed and have rebooted the computer several times to no avail.

I figured this issue with a missing Windows Firewall service might be causing us an issue wherein we are unable to RDP towards the device for whatever reason even after disabling the GPO object/rule we use for the devices.

Any expert advise is appreciated.
Fernando MarambioAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Martin MillerCTOCommented:
If you have access to AD, look for policy where RDP/Remote Access can be disable in a GPO...  not linked to firewall.
0
McKnifeCommented:
Your attachment is missing.
A service won't go "missing". If the service list does not show "windows defender firewall", please run an inplace upgrade as shown here: https://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html
1
bbaoIT ConsultantCommented:
do you see any errors when manually run NET START MPSSVC in a Command Prompt window?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Shaun VermaakTechnical Specialist/DeveloperCommented:
Did you add the RDP firewall exception?
netsh advfirewall firewall set rule group="remote desktop" new enable=yes

Open in new window

https://www.experts-exchange.com/articles/31687/Windows-Firewall-as-Code.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
@Martin Miller
You cannot know whether one or the other comment helped or not. If you think, one comment was more helpful than others, please provide a reason. This time, you distributed the points like this:
Shaun Vermaak's comment #a42503861 (502 points) (3x times as much as the others, for no apparent reason)
Martin Miller's comment #a42503634 (166 points)
McKnife's comment #a42503698 (166 points)
bbao's comment #a42503779 (166 points)

May I assume that you don't know how to divide the points equally using the closure wizard? Just in case, I will object to closure.

@dela Pena - please don't abandon your question, you are letting down 4 people that tried to help.
0
McKnifeCommented:
[forgot to click 'object']
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.