ASUS M5A97 R2.0 BIOS reverts to UEFI, doesn't keep saved changes

I have an infuriating problem. I have a 'new' ASUS M5A97 R2.0. I've updated the BIOS firmware to the most recent version. 2603. My problem is that most of the time when I boot it reverts to wanting to boot UEFI and I have to go into the BIOS and move the 'Boot Priority' setting (see image) to last. I save changes and restart, but for some reason it doesn't keep this change. If fact, I never intend on booting UEFI on this computer and I'd really like to remove this option altogether.

Does any know how I can *insist* that it NOT try booting UEFI?
LVL 1
MarkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
If the BIOS is UEFI, that is the way it is going to boot. Since BIOS is going away soon (next year I think) best to leave it a UEFI.

Secure boot and boot order should be available within UEFI.
0
☠ MASQ ☠Commented:
Have you already tried clearing the Secure Boot Keys in the BIOS Setup?  With those removed the system can't offer UEFI as an option at boot

https://www.qualityology.com/tech/disable-asus-motherboards-uefi-secure-boot/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkAuthor Commented:
John HurstBusiness:
If the BIOS is UEFI, that is the way it is going to boot. Since BIOS is going away soon (next year I think) best to leave it a UEFI.

Secure boot and boot order should be available within UEFI.
Would this not mess up millions of non-UEFI systems, like Linux? With this mode in the BIOS, it boots to a screen with options and the user has to select a boot option. Not necessarily comprehensible to a non-tech user. It also would play havoc with computers intended to be servers which need to boot upon power-up. If a disk is formatted GPT, does it know to automatically boot correctly? My understanding is that MBR and GPT are things distinct from UEFI and "legacy". I have a GPT RAID array, but it boots non-UEFI.

MASQ:
Have you already tried clearing the Secure Boot Keys in the BIOS Setup?  With those removed the system can't offer UEFI as an option at boot
I'll check this out when I'm back in the office tomorrow and post results.
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

JohnBusiness Consultant (Owner)Commented:
Why do you need to boot a UEFI machine with BIOS?  I do not need to do that on any UEFI machine.  What will you accomplish?  UEFI Boot works fine.

An older machine that boots with BIOS will still run. But new machines will only boot from UEFI.  Linux will have to adapt.
0
MarkAuthor Commented:
My problem is that if the machine has a non-UEFI boot device, I get the aforementioned boot selection screen. It doesn't "just boot". I have to reboot, F2 into the BIOS and move the UEFI boot order (which has magically moved to the 1st selection) back to the last selection. "Saving" the BIOS settings does not preserve this order.
0
JohnBusiness Consultant (Owner)Commented:
That is what UEFI secures against.  

Does the ASUS UEFI BIOS not allow you to disable Secure Boot?  It should.
0
nobusCommented:
you should look in the boot override options in the boot section   (scroll down till end)
and set the proper device there
then set the proper device also in boot order option
0
andyalderSaggar maker's framemakerCommented:
Not sure how Chipzilla can kill BIOS via the CPU/chipset. Even if they tweak it that the first instruction comes from a different address than currently there's nothing to stop someone writing a bit of UEFI code that puts it back again; set that code as the boot device and it would appear to any OS subsequently loaded that all the BIOS ROMs were in place.
0
MarkAuthor Commented:
It appears that as long as I'm boot from the installed boot drive I do not get the boot-time option list asking how I want to boot. This seems to occur when I insert a boot DVD. So far I booted from the 14.2 Slackware installation DVD which is old, and from the Acronis Recovery DVD for version 2016-2018. IN any of these cases I get the boot-list when rebooting and the "BIOS" has the UEFI DVD listed as the 1st device.

As this computer will be likely be converted to Linux sometime in the future, and as Linux also does seem to support UEFI (I think), I'll leave this alone for the time being. If it gets to be a problem for some reason I follow MASQ's advise and disable secure boot.
0
JohnBusiness Consultant (Owner)Commented:
Thank you for the update.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.