Windows Server Essentials 2016 Remote Web Access not working

I finally got some free time and decided to try and set up Anywhere Access inside Windows Server Essentials 2016. Didn't go good. Every time I go into the Dashboard and try and configure it I get a error message that "There is an issue with your Remote Desktop Services settings that cannot be automatically repaired. Please contact Product Support".

   I decided to take a look at Roles and noticed that only one role under Remote Desktop Services was installed (Remote Desktop Gateway) so I installed the Remote Desktop Web Access role. Still no luck. Do I need to install and other Remote Desktop roles?

  The only other error I am getting is that ports 80 and 443 are blocked which they aren't because the Windows Firewall is turned Off.

Any ideas?
LVL 15
LockDown32OwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
I'm not experienced with Server Essentials, but on a standard server in order to configure remote desktop you have to install the following services:  RD Gateway, RD Session Host, RD Connection Broker and RD Licensing, as well as RD Web Access if you want to use Remote WebApps in addition to (or instead of) Remote Desktop.
0
LockDown32OwnerAuthor Commented:
Yep. Those are installed. I either get "Forbidden. Access Denied" or the IIS page. Something really wrong with IIS.
0
Hypercat (Deb)Commented:
Are your RD website virtual directories set to use SSL and do you have an SSL certificate appropriately configured and applied to the website and the various remote desktop components? In the standard RDS configuration it's strongly recommended that you use a public certificate authority (like GoDaddy, Verisign, etc.) rather than a self-signed certificate. Which are you using?

And what URL are you using?  Normally the URL would be something like: https://server.domain.com/rdweb.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

LockDown32OwnerAuthor Commented:
Right now the SSL Cert is kind of moot. Even the url you suggested results in the same error as others I have tired. See the attached screen shot....
Capture.PNG
0
Hypercat (Deb)Commented:
Did you follow these instructions (or similar ones) on setting up the remote web access on Essentials Server?

https://docs.microsoft.com/en-us/windows-server-essentials/manage/manage-remote-web-access-in-windows-server-essentials

These instructions are quite different from the steps to set up a standard RDS server, and I'm sure (like the predecessor Small Business Server versions) that the Essentials experience uses built-in procedures to create the remote web site in IIS that are probably different from the standard setup. If you didn't use this "wizard" automated setup method, then there's undoubtedly something that was missed in the configuration during the installation of the RDS services and web configuration.
0
LockDown32OwnerAuthor Commented:
The issue actually turned out to be security on the C:\Windows\Temp folder. How it got changed after running fine for 6 months is beyond me. I have had the exact same thing happen in Windows 10. Leave it to Microsoft......
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LockDown32OwnerAuthor Commented:
It was the definitive solution
0
LockDown32OwnerAuthor Commented:
It worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.