Azure MFA Server (on-prem) error

Hi,

I’m currently testing Azure MFA server, I have applied MFA to my user using a security group when I test I get this error,
I'm not sure why any suggestions?


For security reasons, we require additional information to verify your account
An error occurred
An error occurred. Contact your administrator for more information.
Relying party: Microsoft Office 365 Identity Platform
Error time: Mon, 19 Mar 2018 20:59:50 GMT
Cookie: enabled
User agent string: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

And this in the event log

Encountered error during federation passive request.
 
Additional Data
 
Protocol Name:
wsfed
 
Relying Party:
urn:federation:MicrosoftOnline
 
Exception details:
Microsoft.IdentityServer.RequestFailedException: No strong authentication method found for the request from urn:federation:MicrosoftOnline.
at Microsoft.IdentityServer.Web.PassiveProtocolListener.CheckAuthenticationOptionsForMethods(ProtocolContext context, List`1 authMethods)
at Microsoft.IdentityServer.Web.PassiveProtocolListener.OnGetContext(WrappedHttpListenerContext context)
 

Current Server Setup
2x WAP in DMZ (Server 2016)
2X ADFS (Server 2016)
2x MFA (Server 2016)
Ben SAsked:
Who is Participating?
 
Vasil Michev (MVP)Commented:
Did you configure the AD FS MFA adapter? I'd also recommend testing with IE as the browser, as other browsers might need additional configuration.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.