sdm no longer opening after switch isp

hi I was running my sdm software on one of my win 7 pc no problems and was previously with isp: xln.co.uk - successfully

I have ping connectivity from my router, switch and pc and vice versa

I have now changed to isp: vodaphone  - & installed sdm on my 2nd win 7 pc - but for some reason now sdm will not open a browser & instead it prompts to download:

runapp.shtml

it also throws a notepad file on my desktop showing error on my 1st win 7 pc that was originally running sdm - successfully
my 2nd win 7 pc that I installed sdm after the isp change does not through the below error on my desktop

exception_access_violation (0xc0000005) at pc=0x04f439a6, pid=1124, tid=2628

http://www.wisepccleaner.com/exception_access_violation_0xc0000005_at_pc_0xcccccccc_pid_428_tid_3608.html

when I connected to my vodaphone router a browser did showing saying that it could take a few weeks to fully sync everything or words to those affects but I assumed it meant the speed connection.

I have also uninstalled ie 11 and re-installed and also the same with google but still cannot get sdm to open the software

any help ?

I then decided to open my sdm already installed on my 1st win 7 that has been working and exact same issue so it makes me believe since the change to another isp that something has not quite updated or I need to download a specific update !!

or is it as the above url describes that i may have a bug on both pc's or some software i have installed has caused an issue, but even then as i have not installed anything new on the win 7 pc that was already running sdm successfully prior to the isp change.. now im not sure

so the last thing to do from my end was to re-install clean win 7 & start again just to see

question 1.  can anyone advise  ?
mikey250Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atlas_shudderedSr. Network EngineerCommented:
Are you trying to connect to the router locally or from across the Internet?
0
mikey250Author Commented:
Locally
0
mikey250Author Commented:
Router connected to cisco switch & then direct to win 7 pc
0
Turn Raw Data into a Real Career

There’s a growing demand for qualified analysts who can make sense of Big Data. With an MS in Data Analytics, you can become the data mining, management, mapping, and munging expert that today’s leading corporations desperately need.

mikey250Author Commented:
No extra configs just basic ip connectivity
0
atlas_shudderedSr. Network EngineerCommented:
Can you post a diagram of your connectivity to the router?    PC>Switch>Router?
1
mikey250Author Commented:
Its exactly as you describe:

3 devices on my desk as below using only 2cables

Pc> switch> router
0
atlas_shudderedSr. Network EngineerCommented:
Okay, in that case it isn't going to have anything to do with your ISP.  

Are you able to console or ssh to the router?
0
mikey250Author Commented:
Im local as in sat right by it so was trying to configure it but since the change.

I had not installed anything on the working sdm for a month so pc switched off.

Ok I wil re-install clran win 7
0
mikey250Author Commented:
Wil clean install win 7
0
mikey250Author Commented:
Other than leave the firewall on I habe allowed icmp only.

So im thinking was my firewall off wen installed sdm.. not sure

Will have to check but dont think that caused issue
0
atlas_shudderedSr. Network EngineerCommented:
Is this a firewall or a router?

If it is as firewall (as in ASA), you need to be running ASDM.

If it is a router, you will need SDM.

If it is a router and you have upgraded the image, you need to confirm that you have the web interface image installed, otherwise, the no web interface will be present to attach to.

Please answer:
What is the exact equipment and model type you are attempting to access?
Can you console or SSH to that equipment?
0
mikey250Author Commented:
Ssh is currently not configured

The firewall on my win 7 I meant

My sdm was already working as ising 1841 routers compatible with sdm & ios 12.3 as was about to setup site to site vpn

Firewall is not configured on 1841 via sdm aa yet
0
mikey250Author Commented:
If my sdm was configured with firewall them win 7 firewall could me switched off.

Saying that its not live
0
mikey250Author Commented:
Im sat right by it so of course can console but not there today
0
mikey250Author Commented:
Yes asdm is for asa & im not using it & uninstalled asdm ftom pc prior to installing sdm
0
atlas_shudderedSr. Network EngineerCommented:
What is the version of your SDM and Java?
1
mikey250Author Commented:
Not sure but I think

Sdm 2.5
Java 6.11
0
atlas_shudderedSr. Network EngineerCommented:
JRE 1.5_09
JRE1.4.2_08
JRE 1.5.0_06
JRE 1.5.0_07
JRE 1.6.0_02
JRE 1.6.0_03

These are the supported RE's that I have been able to find for SDM2.5.  Check your Java and confirm that you are using one of the above RE's.
1
mikey250Author Commented:
It was a guess   but not there to check.

I dont understand because if I have been using sdm already & installed exact same java then not sure what you mean ??
0
mikey250Author Commented:
I will check this evening & switch win 7 firewall off & try open sdm again otherwise clean win 7 install etc
0
mikey250Author Commented:
hi you were right I had the wrong java installed.  I must have by accident uninstalled the wrong one as there was 2.

Anyhow I also switched off temporarily the win 7 firewall which told me I had the wrong version when a browser opened.

Java 8 update 161 is the one it updated to automatically & also confirmed via java site as detected correctly etv

The problem I have now is it stated in IE that there was new updates so I clicked to allow whatever updates regarding security.  So thats all done.

I have also deleted & reinstalled sdm & java & started fresh/clean.

after logging on again sdm looks like its going to re-open but now it basically prompts :

"application blocked by java"

I have checked:

internet options: security tab: "scripting of java applets" - is ticked as enabled by default which is was.. but still it blocks sdm.

I deleted all cookies/history etc & reset: "reset all zones to default level"..

closed down all browsers & sdm apps etc

Logged on sdm again but still same issue of being blocked.

Im not sure what url I should allow in the : java exceptions list.. but as the internet is not connected via sdm obviously the url would not be recognised im assuming whether I add the url or not.

ive also rebooted pc & repeated above so not sure

I should be able to access the sdm via http at this point & not https as per my instructions..

Any thoughts ?
0
mikey250Author Commented:
Some of the "activex" are disabled so ive ticked:

- allow activex filtering
- initialize & script activex controls not marked as safe for scripting:  changed from: prompt to enabled

Even when I double click sdm icon it opens a browser below stating:

"ie restricted this webpage from running scripts or activex controls"

- I selected - "allow blocked content"

It then promps me to logon so I do.. by the way the username is blank as only added a password.

It show after logon "do you want to open or save runapp.shtml (12.8 kb) from pc" etc - even if I click open it opens a browser stating I should wait for another browser to open but nothing ever does.

I have set IE as default browser so I ensure this at all times as sometimes google chrome pops up asking if I want to make it the default but I dont select it at all & just close that broswer.

as I said before ive been logging on successfully before this problem

but the above still does not make a difference so ive selected defaults again.

I should be allowed to logon to sdm as all configurations regarding access should be set by default

I even selected via: security tab:

Internet & trusted sites - low

 so lost at this point.

tls 1.1 & 1.2 are ticked by default
0
mikey250Author Commented:
There was 2 adobe flash player  version 28 's installed so I will now install everything including flah player & reboot & start again.

will update you.. if you have any other ideas let me know ?
0
mikey250Author Commented:
Google chrome - also removed
0
mikey250Author Commented:
hi ive found the version of sdm I must have used before as I had saved it in a folder called:

java 1.5 sdm

- jre-1_5_0_04-windows-i586-ps

so I uninstalled everthing again & installed the above & sdm but still get same issue... ive never ever experienced this ever when instslling sdm.

have not got a clue!!
0
atlas_shudderedSr. Network EngineerCommented:
If Java is blocking the app you are going to need to either create an exception in the Java security settings or rip Java out by the roots, reboot and then install an earlier version.
0
mikey250Author Commented:
I'm not sure what to put in the exception list ?
0
mikey250Author Commented:
The message that pops up in the window says exception list but does not show what exactly as it is a url
0
mikey250Author Commented:
Unless it means the window that does not open in which case that URL.. I will give that a try
0
atlas_shudderedSr. Network EngineerCommented:
The IP address of the equipment you are connecting to

https://192.168.x.x for example.

If you are running HSRP on the interface, put in the physicals and the VIP.
0
mikey250Author Commented:
I was able to add http://x.x.x.x in exception list but for some reason after installing SDM even SDM & java said installed successfully the SDM icon does not appear correctly installed for eg just like if a word doc is on pc but as 'word' is not  installed it does not show the icon as expected.

I have now attempted multiple times by reinstalling & reinstalling but same issue even though it shows uninstall as removed completely all files etc.

any advice as I definitely did not want to do a clean win 7 install as definitely something to learn here ??

Much much appreciated if anyone does
0
mikey250Author Commented:
I tried Https://x.x.x.x. for example but same issue
0
mikey250Author Commented:
as the pc has been switched off with both SDM & java uninstalled & I carried out the steps as above ie the re-install & uninstall but did not reboot throughout due to uninstall stated all files completely removed & I did check c:\cisco systems - folder was removed for example
0
atlas_shudderedSr. Network EngineerCommented:
mikey -

The issue that you are relating and symptoms posted still sound like Java is messing you up.  Just to do a couple more checks, are you able to connect to the router via console and if so, could you console in and run the following commands - posting output to the thread:

show flash
show ver
0
mikey250Author Commented:
12.3 iOS it is correct version enough to do SDM config as under direction of info on what iOS works.

All interfaces are up as I have setup

Ping x.x.x.x -t - from both win 7 pc as tests
0
mikey250Author Commented:
As mentioned before I installed:

sdm- 2.5

Java -  jre-1_5_0_04-windows-i586-ps
0
mikey250Author Commented:
I have now uninstalled both of both win 7 pc

All files removed according to uninstall & folder removed from explorer.

Set IE back to defaults - just incase & saw no sign of java installed.
0
mikey250Author Commented:
Correction

1841 router -
flash:c1841-advipservicesk9-mz.124-17a.bin
0
atlas_shudderedSr. Network EngineerCommented:
Can you share the output from:

show flash
0
mikey250Author Commented:
what do u want to see from show flash, surely just the iOS file I showed ??
0
mikey250Author Commented:
I've attached it
0
mikey250Author Commented:
Show flash screenshot
0
atlas_shudderedSr. Network EngineerCommented:
Okay, next question.  Can you ssh or telnet to the router?
0
mikey250Author Commented:
Not using telnet or SSH as physically plugged directly into router 12 inches away.

 no other configs
0
mikey250Author Commented:
I think I'm gonna do clean install & check again
0
mikey250Author Commented:
No issues in boot up of router giving indication of corrupt iOS.
0
atlas_shudderedSr. Network EngineerCommented:
Okay, so you are trying to connect to the router SDM through the console then?
0
mikey250Author Commented:
You asked me that on previous thread yes currently using console port to configure physical interface port with win 7 pc to  install SDM as wanting to setup a site to site vpn for testing.
0
atlas_shudderedSr. Network EngineerCommented:
My apologies.  I missed that.  You aren't going to be able to connect to the SDM via console.  You will need to be connected to the router via enet interface.  You can test that by connecting your station to the router via a crossover cable , configuring your tcp settings as:

Router:

IP 192.168.0.1
Mask 255.255.255.0

PC:
192.168.0.2
Mask 255.255.255.0
Gateway 192.168.0.1

Open SDM on local with target address of 192.168.0.1
0
mikey250Author Commented:
Lol no problems
0
atlas_shudderedSr. Network EngineerCommented:
thanks mikey   give it a go and let me know result.  You should be good and it will put a big chunk of consternation to bed for me.  I've been pulling my hair out trying to figure out what was going on.
0
mikey250Author Commented:
No I am not trying to connect via console for SDM!!!

When I configured the physical router interfaces I consoled in.

I have a Cisco switch with no config in place yet connecting to router & win 7 pc plugged into switch using standard vlan 1 for connectivity so obviously trying to install SDM on win 7 pc

I did explain that before
0
mikey250Author Commented:
Your configuration is what I have as a basic with eigrp as 3 routers so can set up a site to site VPN for testing but obviously need to be able to install SDM which does install & java but shows html type code rather than opening SDM gui
0
atlas_shudderedSr. Network EngineerCommented:
try connecting direct to the router itself via the crossover.
0
mikey250Author Commented:
It's like you said something must not be removing itself after complete uninstall of both SDM & java even though both folders were removed as checked.

I already installed SDM successfully before on same win 7 pc's but one router did not show up/up connection but due to clean install of both router & removal of SDM & java these issues arouse
0
mikey250Author Commented:
You mean plug a crossover cable between pc & switch ?
0
mikey250Author Commented:
I will try but I'm sure they were all straight through but just incase as I removed all cables & replugged maybe that's it
0
atlas_shudderedSr. Network EngineerCommented:
definitely need a crossover to go from PC to router.  Otherwise they won't play well together.
0
mikey250Author Commented:
I will try router also for crossover as you suggest later
0
atlas_shudderedSr. Network EngineerCommented:
Thanks  I just want to rule out the switch
0
mikey250Author Commented:
If it is a crossover cable I will kick myself
0
atlas_shudderedSr. Network EngineerCommented:
For a PC to router direct connection you need a crossover.  If you are using the switch as intermediary then straight through can be used.  I'm just asking for the direct connect to the router to rule out the switch.
0
mikey250Author Commented:
hi I did what you said using a crossover cable & same issue
0
mikey250Author Commented:
Installed java then confirmed install via internet java site

then plugged directly back to router & ping successful

Same issue as before

Shall I just call it a day & give up & clean install win 7 ?
0
atlas_shudderedSr. Network EngineerCommented:
Mikey - That is something that you would have to make the call on yourself.  If you decided to go that route, I would suggest that you load the OS, add your browser, java and sdm only and try from that angle.  If it works, I would log your changes to run down something interfering with SDM later in the load.

The last thing that I can suggest with the current load would be to check your java logs and event logs to see if there is any hint there.
0
mikey250Author Commented:
My win 7 is installed already exactly as you described:

- updates
- SDM
- java

Only

I've done clean install with updates only & installed :

- java 161
- SDM - but SDM is still showing icon as not yellow like it has not installed.

Ludicrous
0
mikey250Author Commented:
Good the SDM icon has now changed back to the yellow icon type the way I would except.

I attempted to login but no SDM open & instead showed that app...html error in window

Even though I've installed java I cannot locate in control panel or when I select start , in order to add:

Https://x.x.x.x
or
http://x.x.x.x

On my other win 7 have appears on  my start but not installed again on that one yet as currently uninstalled.
0
mikey250Author Commented:
Correction the java 161 is what I installed before when it was not working I think but now I've installed:

Js2e runtime environment 5.0 update 4
0
mikey250Author Commented:
Yes no problems saw you message about appointment.
0
mikey250Author Commented:
However I uninstalled js2e runtime environment 5.0 update 4

& Installed the most upto date java 161 which now shows java icon in start menu so I then added both:

Http & Https://x.x.x.x

& Added:

username & password
Http secure-server

On router & but get same

runapp.shtml error appears

Obviously the IE prompts to allow blocked app for eg & I select yes.

Complete nonsense
0
atlas_shudderedSr. Network EngineerCommented:
mikey -

Have you tried this?

https://www.youtube.com/watch?v=zIcf5JSlC0s
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikey250Author Commented:
I'm using crossover cable direct to router.

ping successful

I looked on Google to locate how to locate java logs & it stated to:

Start: type -temp & see various text document files etc but when looking in some not sure where I'm looking. Just like I would notice if it was DHCP logs for eg.

I have ie11 installed on win 7 automatic when I downloaded updates
0
atlas_shudderedSr. Network EngineerCommented:
mikey - did you take a look at the link I posted above?
0
mikey250Author Commented:
Yes thanks for that link it's worked.i have been looking in internet options , advanced tab but did not see that one.wow appreciated
0
mikey250Author Commented:
Dependant on version on java it would not work so installed 6.11
on both sides

Ie 11
0
mikey250Author Commented:
Fingers crossed it will allow me to setup a test vpn as both sides are up/up & can ping either side host & vice versa
0
mikey250Author Commented:
Much appreciated for your help!!!!!

I'm looking on getting the following firewalls:

- checkpoint small business type
- juniper

So gonna put a question out there at a later date
0
mikey250Author Commented:
As I knew I needed correct java version the link that most helped was the URL about allowing IE to open SDM on pc via

Internet options
Advanced tab
Security at bottom
0
atlas_shudderedSr. Network EngineerCommented:
No worries.  Glad things are working for you.  Cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.