unable to delete datastore

i am unable to delete a datastore from vcenter 6.5

its not connected to any host and have no files in it.But when i right click on the datastore    unmount and delete options are greyed.
kastro AbbasiIT consultantAsked:
Who is Participating?
 
Omar SoudaniSystem Support EngineerCommented:
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
check it's not in use.

not used for logging, I/O control not enabled
0
 
kastro AbbasiIT consultantAuthor Commented:
it is not in used not accessible

i/o control is disabled
io-control-.PNG
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
is this a local or shared storage datastore ?

re-scan storage device, reboot server
0
 
kastro AbbasiIT consultantAuthor Commented:
It was assigned from unity 300 Storage to dell chassisM1000e (16 blades) by vcenter .so i already rescan all the servers one by one and its not attached to any of the server,i can't reboot the server as Vmotion is not configured  on vcenter and all are in production
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
it might be worth have a quick look through the logs /var/vmkernel.log
0
 
kastro AbbasiIT consultantAuthor Commented:
Logs of all the hosts or any host
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
the host with the issue.
0
 
kastro AbbasiIT consultantAuthor Commented:
There is no issue with any host .This Datastore Appears only  in the inventory  and Datacenter view. Prod cluster and DMZ Cluster its  not present.
Please view the attached diagrams to understand clearly
Data-Center.PNG
DMZ-Cluster.PNG
Production-Cluster.PNG
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you cannot unmount the datastore from a host, that host has an issue.

Yes, it's cached....

when you look at the Inventory view... does it show what objects and what hosts have a connection to it....

does one or more host have a connection to it ?

does the datastore have anything on it ? any files ?

HA is not using it, as a heartbeat datastore
0
 
kastro AbbasiIT consultantAuthor Commented:
as it is very clear from the snapshots that its not attached to any of the hosts as its not appearing in each host's connected  datastores .also cluster snapshot is not showing the data stores.
There is no file attached also can be seen from the snapshot
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
So what was the issue with your inaccessible datastore which you could not unmount because it was greyed out ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.