ESXi Upgrade from 5.1 to 6 and Red Hat Linux 7.2 (not enterprise RHEL) VM questions

Need advice on VMWare ESXi upgrade considerations from 5.1 to 6.0 regarding a Red Hat 7.2 VM (not Red Hat Enterprise Linux).

I am upgrading VMWare on the 31st from 5.1 to 6.x and have questions regarding a Red Hat Linux 7.2 VM (v.9) on 5.1 and potential issues to be aware of when upgrading ESXi to 6.0 .
Will this VM still run on the new ESXi version?
Any dangers/ considerations for me to be aware of?

This is a critical server and so is the upgrade to 6.0 so anything you can offer to help me be prepared, or to help reduce concerns, would be appreciated.

Thank you!
LVL 14
Michael MachieFull-time technical multi-taskerAsked:
Who is Participating?
Ajay ChananaMCSE-2003/08|RHCSA| VCP5/6 |vExpert2018Commented:
I am more concern the base flavor of  Redhat is same.  Irrespective the enterprise version is having more feature added to it.

It may come on enterprise or not. but for sure  moving VM to 6.5 is safe.

If its normal VM (without RDM) with virtual disk - you may also try cloning the VM on 6.5 and see how that goes.

So far there there  is no issue reported, Expected your Linux 7.2 should work without any issues.
Ajay ChananaMCSE-2003/08|RHCSA| VCP5/6 |vExpert2018Commented:
There is only one KB which I do see below, I am not sure if that will impact your environment. but its good to be on safer side.

Other than this I don't think any issue as you are on supported VM hardware version.

Reference -

version 9 supported upto 65
Michael MachieFull-time technical multi-taskerAuthor Commented:
Good links, thanks.
I'm assuming I will be able to use the stated workaround to disable the VMCI driver to circumvent the potential issue with v.7 .
Does that sound like a correct way to handle this issue?

See quoted copy/paste below and confirm if possible:
Red Hat Enterprise Linux 7:

To resolve this issue for RHEL 7 operating systems, update the Red Hat kernel to:
•      For RHEL7.3, this issue is resolved in kernel-3.10.0-514.el7
•      For RHEL7.2z, this issue is resolved in kernel-3.10.0-327.10.1.el7
•      For RHEL7.1z, this issue is resolved in kernel-3.10.0-229.28.1.el7

To work around this issue, disable the VMCI driver:
1.      Power off the virtual machine.
2.      Connect to the ESXi host on which the virtual machine running using SSH. For more information, see Using ESXi Shell in ESXi 5.x and 6.0 (2004746).
3.      Navigate to the location of the .vmx file of the virtual machine.

cd /vmfs/volumes/datatore/virtual_machine/
4.      Open the virtual_machine.vmx file with a plain text editor:

vi virtual_machine.vmx
5.      Set the vmci.present to false and add a # to the other lines:

For example:

vmci0.present = "FALSE"
#vmci0.pciSlotNumber = "32" = "1868206774"
6.      Save and close the file.
7.      Power on the virtual machine.
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Michael MachieFull-time technical multi-taskerAuthor Commented:
Hi Ajay Chanana,

I have noticed that the link references Red Hat ENTERPRISE Linux specifically. Since my VM is not RHEL (Enterprise Red Hat), does this apply?

I cannot stress enough that the two are not the same, hence my indication that this is NOT Enterprise RHEL, and issues with RHEL may not relate to issues with Red Hat.
Please advise!
Michael MachieFull-time technical multi-taskerAuthor Commented:
I am performing the upgrades this weekend and will post results/ close the question.
Michael MachieFull-time technical multi-taskerAuthor Commented:
Performed a live migration to a test Host on 6.5 without errors or issues. I feel comfortable with the upgrade this weekend.

Thanks for your quick help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.