wireless network computers not seeing each other

Installed a new SonicWall SOHO wireless router and the other computers at home cannot be viewed over the network.

How do I change this?
J.R. SitmanIT DirectorAsked:
Who is Participating?
 
Blue Street TechConnect With a Mentor Last KnightCommented:
Hi JR,

...computers at home cannot be viewed over the network.
Not sure what you are trying to say here but I think you are saying that the wireless devices cannot communicate to the wired devices. If that is correct, you need to make sure the LAN>WLAN and WLAN>LAN Access Rules are set to any, any, all, allow.

By default the WLAN is on a separate network and Zone then the LAN for obvious security reasons and they should be. The WLAN is untrusted for all intents and purposes.

Let me know if you have any other questions!
0
 
J.R. SitmanIT DirectorAuthor Commented:
Okay I'll work on it and post tonight or tomorrow
0
 
JohnBusiness Consultant (Owner)Commented:
You should have the computers on the same subnet if you expect them to see each other.

A good way to set this up is below:

Hook up a LAN port on the Wi-Fi router to your network (LAN port)
Give the Wi-Fi router a static IP address on your network.
Turn DHCP OFF on the wireless router.

This avoids additional routing issues and makes life easy. I hook up all small systems this way and the results are excellent.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
CompProbSolvCommented:
Is the SonicWall the only router?  Blue Street Tech appears to have assumed that it is where John assumes otherwise.

A description of the physical connections would help.  For example, is it: outside cable - modem - SonicWall - all devices  or is it: outside cable - modem/router - some devices and SonicWall ?
0
 
Blue Street TechLast KnightCommented:
I assumed it was the only router because its a SOHO appliance and in a home. It really shouldn't have another router downstream from it. Any routing requirements can be handled by the SonicWALL and in the cases where it can't then it would be under-gunned/mis-sized. In other words, if you need routing power a SOHO would be a bad choice even if it is not the only router because it would not be able to keep up regardless of where the core routing is taking place. It's made for 1-5 users in a small office or home, hence the portmanteau, SOHO. I wouldn't even consider it even in those environments because it can't perform virtual sand-boxing, whereas the TZ300 can (the next model up).

It would help to understand what the goal of needing the different zones to communicate with each other is.

I also didn't mention bridging them (wired and wireless) or having them on the same subnet without bridging because its is a bad security practice, especially with the rise in IoT devices (a hackers paradise). If you don't care about security you could either bridge the networks in the SonicWALL or move the WAP to a switch downstream of the SonicWALL that feeds into X0. By having them on different subnets allows for and triggers inter-zone deep packet inspection as well as all the security inspection services so that when a wireless device is infected and then enters the network its malware and/or tactics would be thwarted as well as the dissemination of the infection.

This is a basic concept of security Best Practices.
0
 
nociSoftware EngineerCommented:
On the WiFi side there is mostly a setting called "isolation" or "client isolation" if that is set, the AP will block traffic between clients.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I changed the WLan>Lan to Allow.  I still cannot see the other computer in our house which is also wireless.  

The wireless computer is connected to the wireless network and has an internet connection.   The main computer is wired.  

The SonicWall is connected to an ARRIS modem.  The ARRIS connects to a switch and the wired computer also connects to the switch.

Hope this helps
0
 
JohnBusiness Consultant (Owner)Commented:
Look at the IP addresses and make sure computers are on the same subnet

You may want to put your modem in bridge mode to take it out of the local loop. You need your ISP for this
0
 
J.R. SitmanIT DirectorAuthor Commented:
They are on the same subnet.  The wired computer has an IP of 192..... the wireless is 172.....  Both have same DNS IP's
0
 
JohnBusiness Consultant (Owner)Commented:
They are on the same subnet.  The wired computer has an IP of 192..... the wireless is 172.....

Not as written - you have two different networks.

1. Make your network the same:  192.168.x.y  Same X for all

2. Same WORKGROUP on all.

3. Master browser is mostly dead:  MAP (NET USE), do not browse.

4. Look at my article on folder sharing.

https://www.experts-exchange.com/articles/16639/Folder-sharing-on-modern-machines.html
0
 
J.R. SitmanIT DirectorAuthor Commented:
I am aware of Network sharing.  What I am specifically trying to connect to is an HP 401n printer.  I have changed the NIC IP address, but so far I cannot seem to find the correct final number to use.  My computer is 192.168.168.65.  I am still trying different numbers for the last digits.  Is there a simpler way to find out what IP's are available for my network?

My ISP isn't available to call today.
0
 
JohnBusiness Consultant (Owner)Commented:
Use the 3 router connection steps I listed above. You need the third group to be the same. The last (fourth) group matters less.

You want ALL devices (including Printers) to be on (say) 192.168.75.x
0
 
J.R. SitmanIT DirectorAuthor Commented:
I just added two other home computers and both got an IP of 172....

why is the wired computer on 192.....
0
 
Blue Street TechLast KnightCommented:
Catching up...

I changed the WLan>Lan to Allow.  I still cannot see the other computer in our house which is also wireless.
You need to do the same for LAN>WLAN.

The SonicWall is connected to an ARRIS modem.  The ARRIS connects to a switch and the wired computer also connects to the switch.
It should be something like this:
ARRIS
    |
SonicWALL
    |(X0)                |(X?, maybe X3)
Switch               WAP (this is most likely your setup)
   |
WAP (this isn't your setup since it would be on the same subnet)

Please verify my diagram is correct. X0 is your 192.168.168.0/24 network and wherever your WAP is plugged into, e.g. X3 that is your 172.16.x.x network.

... What I am specifically trying to connect to is an HP 401n printer.  I have changed the NIC IP address, but so far I cannot seem to find the correct final number to use.  My computer is 192.168.168.65.  I am still trying different numbers for the last digits.  Is there a simpler way to find out what IP's are available for my network?
Verify my diagram above, like I stated previously, if you don't care about security the easiest way to accomplish this is to move the WAP downstream from the switch in my diagram. That will put it on the same network.

So you are trying to get all the computers in your home to print to the HP 401n? Is this the thrust of your question?

You can't just assign an IP address if it is not in the correct network. You need to do what I said above.
0
 
JohnBusiness Consultant (Owner)Commented:
You need to follow my steps above:

Hook up a LAN port on the wireless router to a LAN port on the modem.

Give the Wireless router a static 192.168 address on your main network.

Turn DHCP OFF on the wireless router
0
 
J.R. SitmanIT DirectorAuthor Commented:
Arris to SonicWall X1.  Sonicwall X0 to Switch, Switch to Computer

Yes the entire goal is to connect to a wired printer
0
 
JohnBusiness Consultant (Owner)Commented:
Make sure you follow my steps and then give your printer a static IP on your network.

I have 3 computers, two phones, one printer, two routers and one modem all on ONE network. Switches will just follow along
0
 
Blue Street TechLast KnightCommented:
OK is the SOHO your WAP (Wireless Access Point) or do you have another?
0
 
J.R. SitmanIT DirectorAuthor Commented:
Yes the SOHO is the WAP connected to the ARRIS modem
0
 
Blue Street TechLast KnightCommented:
Ok, so I have already illustrated your options in my previous comment (https:#a42510213). If you don't care about security then create an L2 bridge for both networks (LAN & WLAN) in your SonicWALL.
0
 
J.R. SitmanIT DirectorAuthor Commented:
@John

I guess I am missing something you're trying to tell me.  When I connect the LAN from the modem to the LAN on the SOHO, I lose internet.
0
 
JohnBusiness Consultant (Owner)Commented:
Did you give the Sonic Wall a 192.168. static IP on your Arris modem
0
 
J.R. SitmanIT DirectorAuthor Commented:
Yes, I care about security.  Prior to buying the SonicWall, I had a Netgear, which was much easier to set up.  However, I was informed that the security was weak.
0
 
JohnBusiness Consultant (Owner)Commented:
Your network can be secure. I have never been breach in 2 decades.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I do not know how to access the ARRIS settings.  It is provided by Verison.
0
 
JohnBusiness Consultant (Owner)Commented:
You can put your Router in Bridge Mode and use the Sonic Wall as your main router. That will work as well
0
 
Blue Street TechLast KnightCommented:
It is easy to tell if you have NAT or Bridge Mode in your ARRIS but this has nothing to do with your question...I don't see why we are off on this tangent.

To determine the configuration of your ARRIS login to the SonicWALL and tell me what the X1 IP address is. If it is a private address then the ARRIS is in NAT Mode which again has no baring on your problem.
0
 
JohnBusiness Consultant (Owner)Commented:
Ask your ISP to put it in Bridged Mode
0
 
J.R. SitmanIT DirectorAuthor Commented:
ports
0
 
JohnBusiness Consultant (Owner)Commented:
Either:

1. Make your Sonic Wall the main router (174. x external in and 172. x internal out) and make everything you have 172. x This will work. Been there, done that. Put your Arris modem in Bridged mode to do this.

2. Make your Sonic Wall an AP as I described. Means giving the Sonic Wall a 192.168.x address and all you have on 192.168 addresses. Works. Been there done that.

So pick 1 way of the two above and hook it up..
0
 
J.R. SitmanIT DirectorAuthor Commented:
Can I change WO to 192.168.x
0
 
Blue Street TechLast KnightCommented:
Can I change WO to 192.168.x
No, you cannot! Each Interface must have a unique IP assignment. Go ahead and try it...it will error out.

OK so again there was no need to determine if the ARRIS is in Bridge Mode or not since that has NOTHING to do with your problem but now we definitively know your ARRIS is in fact already in Bridge Mode because you have a Public IP assignment for X1 and you can connect to the Internet successfully.

@John is completely wrong...you can't assign two Interfaces with the same IP address. Both your suggestions are not achievable. You can only Bridge two Interfaces to achieve this.

@John -
Your network can be secure. I have never been breach in 2 decades.
That you are aware of. I'd bet you have had infections that you don't even know about. Experience doesn't mean it is right or the right way of doing things...tried and proven logic, standards/methods, and Best Practices on the other hand are. What you are saying is again not technically accurate and goes against fundamental security practices. It is our job as experts to correct each other when there is incorrect information - that makes everyone improve their knowledge and continue learning. It is not personal. Because you have not had something occur means literally nothing on its own. "It hasn't happened to me therefore I must be safe or have defense mechanisms in place to prevent such attacks" is not a security posture. Maybe you have been lucky or are the exception to the rule but the exception doesn't prove the rule in security.

Literally it is impossible to secure L2 communications unless you have two things in place: a) multiple subnets (L3) and b) a device that can inspect such traversing traffic (such as a SonicWALL) from what I already explained above.

There are too many tangents. This is very straightforward but you need to be methodical. For everything that is post acknowledge you have done & ask questions if something doesn't make sense:
a) Create the Access Rules so that WLAN>LAN and LAN>WLAN are both set to allow all. Then see if you can ping the printer from a wireless device. If you can but still cannot connect to the printer then it may be a limitation of the printer, in which case you will need to perform B below
b) Bridge the two Interfaces X0 & W0.

Here is how to configure the Secondary Bridge Interface so that the Primary Bridge Interface will be X0 and all devices will be on the 192.168.168.0/24 network
We are going to create the X0 interface to act as the Primary Bridge Interface.
1. Login to the SonicWALL and go to Network > Interfaces
2. Click the Configure icon in the right column of the X0 (LAN) interface.
3. In the IP Assignment drop-down list, select Layer 2 Bridged Mode.
4. In the Bridged to drop-down list, select the W0 interface.
5. Click OK.
0
 
JohnBusiness Consultant (Owner)Commented:
I do not know the specific box, but on any of the numerous boxes I have used it is in the LAN settings (not WAN) and that is where you set the LAN address, and turn DHCP OFF.
0
 
JohnBusiness Consultant (Owner)Commented:
@John is completely wrong

That is disgusting. I am not completely wrong. How could what I do work for years and years on end if totally wrong.

Goodbye
0
 
Blue Street TechLast KnightCommented:
You need to provide feedback from my last post toward the bottom (https:#a42510679) starting at the "There are too many tangents." paragraph, so I can help you resolve this.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I'm out running errands as soon as I get back to the computer I will post. Thank you for your help
0
 
Blue Street TechLast KnightCommented:
Sounds good!
0
 
J.R. SitmanIT DirectorAuthor Commented:
Pinging from the wired works.  Pinging from the wireless returns 3 of 4 successful pings

In the Bridged to: my only choice is XO.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Also there two access rules already existed.  I just changed the WLA>LAN to allow
0
 
Blue Street TechLast KnightCommented:
Can you screenshot the access rules for both WLAN>LAN and LAN>WLAN?

I'm thinking there are two for IPV4 & IPv6 but I need to verify what they are.

Now that you have changed that rule; ping again from the WLAN and verify all pings successfully.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I just tested and was able to add the printer.  
Do you think"allowing" the WLAN>LAN was the solution?
0
 
Blue Street TechLast KnightCommented:
Yes, you need to have WLAN>LAN and LAN>WLAN set to allow as I mentioned in my first comment (https:#a42510109). That was always the solution because Access Rules, as their name means, provide access to each Zone. So by allowing them that allows communication between the Zones.

My first comment is the one you should select for the solution.

Does that make sense?
0
 
J.R. SitmanIT DirectorAuthor Commented:
wlan>lan
lan>wlan
0
 
Blue Street TechLast KnightCommented:
Perfect! You are all set.
0
 
J.R. SitmanIT DirectorAuthor Commented:
thanks for hanging in there to solve this.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Thanks again.
0
 
Blue Street TechLast KnightCommented:
My pleasure and now your wireless (WLAN) traffic will be inspected as it communicates with your LAN devices! Glad I could help and thanks for the points!
0
 
J.R. SitmanIT DirectorAuthor Commented:
Saved me from buying a Wireless printer.
0
 
Blue Street TechLast KnightCommented:
Nice!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.