Install.php for Moodle on CentOS server with nginx (like apache) is not letting me finish my web-server. I can't get past localhost to use a test.php file

Can't access test.php on web-server as first step to Install Moodle on CentOS 7 with NGINX instead of apache.  I can see the nginx page on my server by typing 127.0.0.1 or localhost  but if I try to go to moodle/admin/cli/install.php  I get a 404 error. I tried to put a test.php file everywhere like I am used to doing with apache on Ubuntu and windows but I'm not having any luck.  This is a hyper-v virtual server as I always use with access right now inside my network.  I have edited three main files below.  I have been following this link step by step and this is the last and easiest step but I can't seem to figure out what I'm missing.  I don't have to have https - I'm fine with http but am not sure how to change that in the conf file.  

link I'm following: https://www.howtoforge.com/tutorial/how-to-install-moodle-32-on-centos-7/

The files I'm trying to edit to make it work
      /etc/nginx/conf.d/moodle.conf
       /etc/nginx/nginx.conf
      /var/www/moodle/config.php

One clue I have is I read fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;  What this line does is tell PHP which file it should execute, without this nginx and PHP cannot work together.
I'm getting 403 error:  "403" is actually an HTTP status code that means that the web server has received and understood your request, but that it cannot take any further action
I'm not sure what the difference btwn fast_param and fastcgi or if those matter.  

Thanks in advance for helping me find a solution so I can do the last easiest step installing Moodle (install.php) which I can't access.  
Thanks
LVL 1
hilmarusdAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam Simon NasserIT Support ProfessionalCommented:
can you refer to this tutorial on Installing NGINX and Moodle on CentOS 7? maybe there is something missing in your installation
https://www.howtoforge.com/tutorial/how-to-install-moodle-32-on-centos-7/
 https://websiteforstudents.com/install-moodle-3-3-2-ubuntu-17-04-17-10-nginx-mariadb-php-support/
0
hilmarusdAuthor Commented:
Thanks Sam!
I checked out this link and compared it to all the steps in the main link I am following.  
They are almost the same but there were two lines I tried  - one was to disable apache good idea but it said it was not installed.
The next one is sudo ln -s /etc/nginx/sites-available/moodle /etc/nginx/sites-enabled/
I read that ln means to set a hard link which I kinda get but not quite.  First, I don't have a site-available nor sites-enabled folder which I have always wondered about if that's my problem. But the directions at my main link also put Moodle into a different directory slightly - mine is at
/var/www/moodle/ instead of the usual /var/www/html/moodle/ which should be fine but not having those sites-enabled could be part of my problem.  My conf is also located differently here: /etc/nginx/conf.d/moodle.conf  as per the directions in my link.
I also think I don't have https set up right so I would like to try the step 6 code from your link which seems more straightforward than theirs.

Problem is my location differs so I have not yet tried.  Working on that now and will get back to you.

Thanks again for sticking with me!
0
hilmarusdAuthor Commented:
Also their conf starts out differently with
# PHP Upstream Handler
upstream php-handler {
    server unix:/run/php-fpm/php-fpm.sock;
}
 then this part is similar with server and listen 80 but I'm not sure what the above part does or if I can leave it out
# Nginx redirect HTTP to HTTPS - moodle.hakase-labs.com
server {
    listen 80;
0
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

hilmarusdAuthor Commented:
I think my server ip address maybe changed too as I tried this same command and got a new result this week than last week
dig +short myip.opendns.com @resolver1.opendns.com  

Also I did not know what to put for the server so I tried all these in one line but I'm not sure if that is correct.

server_name localhost 127.0.0.1 http://moodlec.waterford.k12.ca.us  216.64.xxx.xx  208.67.xxx.xxx;  I have real numbers there I just thought I would be safer I heard I should not share my ip address out with the world.

is that ok to put them all in one line? I'm using every one I can think of that might work hoping one works but maybe I should try them one at a time.  
Nginx now complains on restart and going to localhost on the web no longer says welcome to nginx
0
hilmarusdAuthor Commented:
I finally gave up on CentOS!  after a few months trying to make it work. I went back to ubuntu and was able to do the same thing in 1 day.  my hats off to the CENTOS people! I'm out.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.