MG3500 Scanning Not Working on HighSierra

Hi Experts,

I have a CANON MG3500 at home using it with my MacBook. It used to be working fine on both printing and scanning. I'd re-installed the MacOS version HighSierra (10.13.3) yesterday, and found that the printer can now only print but not scan.

I remember I didn't need to install anything specifically for this printer on Mac. Once it's connected via AirPrint, everything should just work. On the print queue app, there should be a scanner button on the right.  But this time, after reinstalling HighSierra, I can't see the scan button anymore.  

I tried this printer driver from Canon website, but didn't work either.
http://support-th.canon-asia.com/contents/TH/EN/0100537702.html

BTW, before reinstallation of MacOS, i was already on the same HighSierra.


Thanks
JV
Jimmy VadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sajid Shaik MSr. System AdminCommented:
the installed is the printer driver so go with the following
MG3500 series Full Driver & Software Package

http://support-th.canon-asia.com/contents/TH/EN/0100538701.html

if still issue remains upgrade the printer firmware

http://support-th.canon-asia.com/contents/TH/EN/0400150602.html

and install the package again..

all the best
0
Sam Simon NasserIT Support ProfessionalCommented:
0
Jimmy VadAuthor Commented:
tried the full driver and software package, but couldn't get it installed on HighSierra at all ...
the setup app doesn't popup anything on the screen...

i managed to upgrade the firmware though.

result is the same so far... still can't get the scan button back
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Sam Simon NasserIT Support ProfessionalCommented:
are you working via wireless? try connecting to USB cable and try the scan. in order to determine where is the issue.
0
Jimmy VadAuthor Commented:
Found the solution.

When adding the printer, in the "Use" field, should use AirPrint, rather than "Canon MG3500 Series".
Dunno why, but this brings back the Scan button.

THanks for your input.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jimmy VadAuthor Commented:
found the solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.