• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 49
  • Last Modified:

Wireless button not working

Compaq presario cq57 wireless/f12 button stays Amber and will not connect to wifi. The laptop was shutdown improperly by pushing and holding the power button. I had to reinstall Windows 7 just to get the rest of the laptop to work. Please help
0
Jennifer Meyers
Asked:
Jennifer Meyers
  • 2
1 Solution
 
Sam Simon NasserIT Support ProfessionalCommented:
go to device manager (right click computer - manage - device manager), is it configured properly?

these are the drivers - i dont whats the driver exactly, but one them will work
atheros http://ftp.hp.com/pub/softpaq/sp53001-53500/sp53261.exe
ralink http://ftp.hp.com/pub/softpaq/sp55501-56000/sp55843.exe
realtek http://ftp.hp.com/pub/softpaq/sp52001-52500/sp52212.exe
0
 
JohnBusiness Consultant (Owner)Commented:
You want to the correct driver as noted above. There is probably a little Wi-Fi switch on the side of the machine. Turn that OFF then ON to make sure it has connected.
0
 
nobusCommented:
i suppose the wifi is not installed; check that in device manager; here's how to identify it :

if you have  unknown devices in device manager, you can use this procedure to identify them :

1- visit the motherboard manufacturers support site, for downloading drivers
2- use windows update >optional updates to find them

3- Start>Programs>Accessories>System Tools>System Information.
Now select  "Components" and highlight "Problem Devices".
All hardware devices with a driver problem will be listed here.
Make a note of the first line of the PNP Device ID line of the entry. It will show a Vendor number and a Device number (VENxxxxDEVxxxx) both four digits long.
Look up those numbers here:    pcilookup.com
This will tell you the manufacturer and the chip number.  
Check the manufacturer's website first or google them - or post them here

4- If your LAN is running, you can also use windows update> optional drivers, or  use a driver update software
0
 
Sam Simon NasserIT Support ProfessionalCommented:
drivers from manufacturer website for the mentioned model, and no feedback, assue worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now