windows 10 PRO edition is not listening on port 3389 for RDP connections.

windows 10 PRO edition is not listening on port 3389 for RDP connections.

when I RDP to my desktop2 laptop from desktop1 I received standard error ( remote desktop can't connect remote computer for one of the reasons..)
I then checked the service on desktop2  and it is running, I disabled the third party anti virus, disabled windows firewall and still had the same error on desktop2. I can successfully ping from desktop2 to desktop1. I installed latest updates too but did not help.

I then performed telnet localhost 3389 and noticed that port is not listening. I also confirmed this by running portQryUI and had the same result. also tried to telnet to desktop2 from desktop1 and had the same result.

I checked the registry on desktop2  and it is set to listen on 3389

can you please suggest what else I can try?
kuzumAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NVITEnd-user supportCommented:
After those adjustments, please see if reboot helps
0
ReeceICT ConsultantCommented:
Are you trying to connect with a computer on the same network or outside the network (ie. over the internet).

If you right-click "This PC", choose Properties then click Remote Settings.  Make sure "Allow remote connections to this computer" is ticked.  If it isn't, tick it and restart the PC.
1
kuzumAuthor Commented:
Hi, thank you for responses. Yes i have did the basics and had no luck.
My pcs are on the workgroup not domain. I am trying to access on LaN and next step will be connecting from outside.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

ReeceICT ConsultantCommented:
What if you change the RDP port to a different number (eg. 3390) via the registry.  (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber).
Allow this port (in and out) in Windows Firewall > Advanced settings.
Restart the computer.

Try connecting to the PC from the other PC via LAN_IP:3390 (don't use the computer name)
0
JohnBusiness Consultant (Owner)Commented:
Also check if Network Discovery is ON, that WORKGROUP is the same on both / all machines, and that the Network Card is set to Private (not Public).
0
Andrew LeniartFreelance Journalist & IT ConsultantCommented:
Is your Router forwarding Port 3389 to the specific PC? That's needed.
0
arnoldCommented:
Is remote administration enabled on the system, properties of computer, advanced system settings,
Check the firewall settings to make sure RDP are permitted through the type of network you have set in the network and Internet sharing center.
I.e. If the workgroup reflects that the system is on a public network, the majority of services on the system will be blocked by the firewall on the incoming side.
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You should check if the port is really open with something listening on it, e.g. with
  netstat -an | find "3389"
in a cmd prompt. Because of your portqry and local telnet attempts I don't think so.
0
Sam Simon NasserIT Support ProfessionalCommented:
basics:
right click computer - properties - remote

in the lower part (remote desktop) either choose the second option or the third one. if the second one do not work, click the third option and in the select user type everyone and test.
0
kuzumAuthor Commented:
Hi,

I have tried and checked what has suggested here but had no luck. Lastly tried it with port 3390 instead and created a port rule for it both for inbound and outbound but still cannot see port 3390 is listed when i do netstat -an

please see the firewall rule attached. any more ideas please?
0
arnoldCommented:
it might be denied by GPO.
0
kuzumAuthor Commented:
Machines are on workgroup and there is no domain gpo
0
arnoldCommented:
What about network and Internet center, in which type of network, private/home, work, public is this system being reflected?

netstat -an | find ":3389"
Or test for 3390 and see if there is a listen live for either.
0
PerarduaadastraCommented:
Can you confirm that the Remote Desktop service is actually running? Check in task manager - its startup type may be set to disabled.
0
kuzumAuthor Commented:
@arnold    netstat -an | find ":3389"

returns an emty line not sure what that means?

@Perarduaadastra  services was running but was set to manual and I set it up to auto start.

thanks for responses. I am running out ideas?
0
PerarduaadastraCommented:
Run this command:

netstat -a -p tcp

and wait a few seconds for it to complete. The list is organised by IP address and port number, so scroll up to the top and look for a line that reads:

TCP    0.0.0.0:3389    <name_of_your_computer>:0        LISTENING

If there is no such line then nothing is listening on that port, which means that either the service isn't running or that it's listening on a different port. When you changed the port to 3990, did you do this in decimal or hex? The edit window defaults to hex even though the port number is in decimal so it's easy to enter a decimal value in hex without realising it, in which case you would have told the RDP service to listen on port 13200 decimal! Likewise, if you repeated the error when changing it back to 3389 you would have told the service to listen on port 13193 decimal.
You don't say one way or the other in your posts, but when you change the RDP listening port in Windows you have to reboot the machine before the new setting takes effect.
0
kuzumAuthor Commented:
@Perarduaadastra

run the command and I cannot see the line we are after

also, curent port number in registry is set to listen on 3390 and it is in Hex. format.

I changed it normal 3389 and rebooted the machine. I will run the same command again will post the result here.
thank you.
0
kuzumAuthor Commented:
OK- this is very strange to me..

when I run this command netstat -a -p tcp  I had no port 3389 or 3390 ( manual change) was showing in the list.

I noticed from the GUI ( screenshots are attached) RDP is listening on different port.

I checked the registry and PortNumber is set to 3389 !  

when I do telnet localhost 13193 it returns no errors and logs in fine. how is this possible and where is this info saved in registry?
Capture.PNG
Capture2.PNG
0
PerarduaadastraCommented:
This is happening because you made the same error with port 3389 as you did with 3390 - you entered the decimal port number in the hexadecimal field. 3389 in hex is 13193 in decimal. When you look at the values displayed in the PortNumber DWORD of the RDP-Tcp key they should look like this:

0x00000d3d (3389)

The number in brackets is the RDP listening port number in decimal. The one without brackets and beginning 0x is the same number expressed in hexadecimal notation. You've mistakenly entered the decimal port number as a hexadecimal value (because the default notation for this DWORD is hexadecimal), and Windows has obligingly accepted this and converted it to 13193 in decimal because it did what you told it do and not what you meant it to do!

It's dollar to a doughnut that the values in the RDP-Tcp PortNumber DWORD in your registry currently look like this:

0x00003389 (13193)

... which is wrong if you want to use the default decimal port value of 3389 - it needs to look like the one a few lines up in this post.

The fact that you can telnet to the erroneously set port suggests that when the correct values are entered in the registry and the machine is rebooted, RDP will function as expected. Be aware that this value is in three different locations in the registry, so enter RDP-Tcp in the regedit Find dialogue (invoked with Ctrl-F) and use the Find Next button to locate and edit the other occurrences; the third one may already have changed to the desired value by the time you get to it.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kuzumAuthor Commented:
This is exactly what was setup on the machine, great explanation. Thank you. It all works fine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.