Missing DLL LogonUI.exe - System error.

LoponUI.exe - System Error.
The program can't start because OLEAUT32.dll is missing from your Computer. Try reinstalling the program to fix this problem.

Okay the background. This PC did something very similar before. I could never get it to work by replacing the missing DLL files. I ended up reinstalling the OS (Windows 7), Clean install. I checked it worked, updated with all the available updates. Let it sit around a couple days and fiddled with it occasionally to make sure it worked. I sent it how to it's owner and the first time she tried to use it this pops up. It's worse that it was before. What the hell is causing this? I did run a dskchk and got no errors.
rogerb_txAsked:
Who is Participating?
 
Andrew LeniartSenior EditorCommented:
Well if I could figure out how to get into it, I could try that. Can't login.
Rather than doing it in the Windows environment, reboot and tap the F8 key. You should get an option to go to a command prompt along with Safe Mode etc.  Try doing it from the command prompt there.

I hope that's helpful.

Regards, Andrew
0
 
Andrew LeniartSenior EditorCommented:
Did you try a SFC /SCANNOW on the computer in an elevated command prompt? That could help.

Regards, Andrew
0
 
rogerb_txAuthor Commented:
Well if I could figure out how to get into it, I could try that. Can't login. Tried in Safe mode same problem. I'd just reload it again, but what the hell is causing this?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
rogerb_txAuthor Commented:
Command prompt, geez I'm a dolt. Haven't thought of that in years.
0
 
rogerb_txAuthor Commented:
Nope still wants me to login. Guess I'll have to boot it with TRK and see if the file is there.
0
 
rogerb_txAuthor Commented:
Replaced the file using TRK. Now I can login. But...no Windows says it isn't a valid copy. Which it is, used Lenovo's restore partition to install it when I did the clean install. Ugh! Hate Windows.
0
 
rogerb_txAuthor Commented:
Well I got it working. Thanks for the suggestions. Still have no clue what happened.
0
 
Andrew LeniartSenior EditorCommented:
Glad I was able to help a little Roger and thank you for returning to close your question. Much appreciated.

Regards, Andrew
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.