2008R2 Group Policy with Windows Updates on Windows 10 clients, 2012 WSUS Server

Group Policy with Windows Updates on Windows 10 clients

I am having trouble getting my Windows 10 machine to install updates automatically and then prompt me to reboot (my objective of a test with WSUS).  I am testing a GPO on a network, so it may be used with the rest of the network users.  My machine is currently the only client applying a new GPO that is set to "Download updates automatically and install at scheduled time" (12pm) every day.  When I run RSOP.MSC I can see the settings are present on the machine.  When I check the Windows Update Settings screen, I can see that "some settings are being controlled by another computer" (the WSUS server) and that "some updates are available" - but it never installs them.  I instead have to click the INSTALL button manually.  Is this something to do with the Windows 10 OS?  or maybe my GPO is not configured properly?  The WSUS server is windows 2012, on a 2008R2 AD network.

thanks for your help
Damian_GardnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael PfisterCommented:
Download the policy templates matching your build of Windows 10 from the Microsoft Download Center. Copy them either to the template store on your system you're editing the GPO or, in case you have one, to the central policy store under SYSVOL
Win 10 has a few additional settings regarding Windows updates.

HTH
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonNetwork AdministratorCommented:
You need to configure the group policy for "4 - Auto download and schedule the install "

Look over

https://technet.microsoft.com/en-us/library/cc512630.aspx
0
Damian_GardnerAuthor Commented:
yes - this is my current configuration.  in spite of this setting - and oin spite of confirming the client is indeed set to the #4 option - it still shows this behavior.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Damian_GardnerAuthor Commented:
its is scheduled to INSTALL each day at 12 noon. it does not install, however.
0
DonNetwork AdministratorCommented:
Are the updates approved in WSUS ?? Does the computer have a pending reboot ?? Is this setting enabled ? "Allow non-administrators to receive update notifications"
0
Hypercat (Deb)Commented:
Normally Windows 10 is pre-set to prevent restarting except during a specified time frame.  Have you checked these settings on the Update & Security/Windows Update page?

Also, do you have any of these group policies enabled:

"Allow automatic updates immediate installation"?
"No auto-restart with logged on users"?
"Do not connect to any Windows Update Internet locations"?
0
Damian_GardnerAuthor Commented:
sorry for the delay guys.  here's what I see:

"Allow non-administrators to receive notifications" is enabled
"Allow updates immediate installation" is enabled
"No auto-restart" is not enabled
I don't see one for "Do not connect to Windows Update Internet locations"

The updates are approved - the machine is simply not installing them automatically.
0
Hypercat (Deb)Commented:
Are you leaving the workstation logged off during the installation time frame?  My experience with Windows 10 is that self-update behavior with WSUS is a little spotty and seems to depend to some degree on what version of Windows 10 you're running.  If you're running the latest version (1709), though, as long as the machine is logged off during the installation time period AND the time frame DOESN'T fall within the "Active Hours" you've set , the updates seem to self-install and restart the machine, just like a Windows 7 workstation would.  IOW, if you are using a scheduled install, then the Windows 10 workstations will install the updates and restart but ONLY if you're logged off , regardless of whether you have the "No auto restart" option enabled or not.
0
Damian_GardnerAuthor Commented:
ok - I see.  well I've been leaving the workstation locked, actually - not logged off.  Are the active hours set on the workstation, or in the GPO?
0
Hypercat (Deb)Commented:
On the workstation. I think it's only on Windows 10 v.1607 and above, if I recall correctly.  It's on the Update and Security/Windows Updates page
0
Damian_GardnerAuthor Commented:
ok.  I just checked, and this is Version 1511 - so its older I guess.  what i'll do is log off my computer tonight and see what it does.
0
Damian_GardnerAuthor Commented:
So believe it or not, this is still not resolved.  I've also determined that its not only Windows 10 clients, but Windows 7 clients as well - they take the updates that are available from the WSUS server - but they do not install them automatically, in spite of the #4 option specified in the GPO to "download AND schedule install".  Perhaps they need some kind of update (ironically) in order to fix this?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.