Having trouble pinging over a trunk to another router.

I am trying to ping from eastcore to company1-stack  

they are connected with a trunk and i can ping from eastcore to company1  (on the vlan1 address) but i cant ping from company1 to eastcore on the vlan 1 address.  on the transport vlan of 192.168.168.X I can ping both ways.  I have a route set up that says anything bound for eastcore vlan1 send over vlan3 and the opposite on the other server... but cant seem to get it to work.  Here are the configs...



EastCore#
EastCore#show run
Building configuration...

Current configuration : 4704 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname EastCore
!
!
!
!
!
clock timezone PST -8
!
!
!
ip routing
!
!
!
no ip domain-lookup
ip name-server 10.10.10.1
!
!
spanning-tree mode rapid-pvst
!
!

!
interface FastEthernet0/24
 description T INTERNET
 switchport access vlan 2
 switchport mode access
 shutdown
!
interface GigabitEthernet0/1
 description *WestCore Link, TenGig 5/1*
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 description T Switch
 switchport trunk allowed vlan 5
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 10.10.0.5 255.255.255.0
 ip helper-address 10.10.1.1
 ip helper-address 10.10.1.2
 standby 5 ip 10.10.0.1
 standby 5 preempt
 standby 6 ip 10.10.0.2
 standby 6 priority 110
 standby 6 preempt
!
interface Vlan2
 description ***T***
 mac-address 000a.4153.3c01
 no ip address
!
interface Vlan5
 description ***T***
 mac-address 000a.4153.3c0b
 ip address 192.168.168.1 255.255.255.0
!
interface Vlan10
 mac-address 000a.4153.3c03
 ip address 10.10.1.252 255.255.255.0
 ip helper-address 10.10.1.1
 ip helper-address 10.10.1.2
 ip helper-address 10.10.1.24
 standby 19 ip 10.10.1.253
 standby 19 preempt
 standby 20 ip 10.10.1.254
 standby 20 priority 110
 standby 20 preempt
!

ip classless
ip route 0.0.0.0 0.0.0.0 10.10.0.3
ip route 10.10.0.0 255.255.0.0 Vlan1
ip route 192.168.4.254 255.255.255.255 10.10.0.3
ip route 192.168.75.0 255.255.255.0 Vlan5
!
ip flow-export version 9
!
!

logging 10.40.0.21

line aux 0
!
line vty 0 4
 logging synchronous
 login
 privilege level 15
line vty 5 15
 logging synchronous
 login
 privilege level 15
!
!
ntp server 148.167.132.201 key 0
!
end









company1stack#show run
Building configuration...

Current configuration : 2411 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname company1stack
!
!
!
!
!
clock timezone PST -8
!
!
!
ip routing
!
!

no ip domain-lookup
!
!
vtp domain T
vtp mode transparent
!
spanning-tree mode pvst
!
!
vlan 2
 name T_INTERNET
!
vlan 3
 name T_NETWORK
!
vlan 5
 name connectionT
!
vlan 20
 name voice
!
vlan 75
 name TWCWorkstations
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 2
 switchport trunk encapsulation dot1q
 switchport mode access
 spanning-tree portfast
 shutdown
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
 switchport mode access
 spanning-tree portfast
!

interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 5
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
!
interface Vlan1
 description DATA
 ip address 192.168.75.254 255.255.255.0
 ip helper-address 192.168.100.16
!
interface Vlan5
 mac-address 000c.cfac.9601
 ip address 192.168.168.2 255.255.255.0
!
interface Vlan20
 description voice
 mac-address 000c.cfac.9602
 ip address 192.168.20.254 255.255.255.0
 ip helper-address 192.168.100.16
!
interface Vlan75
 mac-address 000c.cfac.9603
 no ip address
 ip helper-address 192.168.100.16
!
interface Vlan99
 mac-address 000c.cfac.9604
 ip address 192.168.99.254 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.75.222
ip route 10.10.0.0 255.255.255.0 Vlan5
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
 exec-timeout 0 0
!
line aux 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end
publicvoidDirector of ITAsked:
Who is Participating?
 
Craig BeckCommented:
no ip route 10.10.0.0 255.255.255.0 Vlan5
ip route 10.10.0.0 255.255.255.0 192.168.168.1
0
 
publicvoidDirector of ITAuthor Commented:
Craig, thank you...     that did work.  Can i ask why?  why is there a difference if i send it to the ip address of the vlan rather than the vlan itself?


Thanks again!
0
 
Craig BeckCommented:
Sending to the VLAN won't work unless you use a point-to-point link or proxy-ARP.
0
 
publicvoidDirector of ITAuthor Commented:
As you saw from my other question, I hadn't made the change that you said yet but I did now and it has another issue but i will keep it on that question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.