Exchange Quota Limits wrong

On my Exchange 2016 server when I run
Get-mailbox -database DB01

Open in new window

in the Exchange Powershell most of the list of users shows the ProhibitSendQuota as "unlimited" there are a few showing the correct limits setup in the Database Settings.

To get those correct, I had to set specific limits in the Mailbox, then remove them and they started showing the database Limits.

To further complicate, when a user showing Unlimited in the list opens Outlook, the usage is showing as xxGb free of 2GB (which is the correct limit).

Checked the
get-mailbox -ResultSize "unlimited" | Where-Object {$_.UseDatabaseQuotaDefaults -eq $false}

Open in new window

this lists all mailboxes as being set to use the Database quota's.

My question is, Outlook is reporting the correct amount of space allowed but the Exhcnage powershell is not. Which one is going to be actually used?? is there anyway to fix the sizes in the Excahgne Pwershell.

Thanks
motorhogAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hardik DesaiIT Architect and TrainerCommented:
It is because of the option selected on the mailbox the shell is displaying unlimited.
quota.png
If it is changed to the option selected in the below SS, shell will display the correct option. Not sure if that is bug or MS have left it that way.
quota1.png
0
motorhogAuthor Commented:
But there is a limit set in the Database,

chrome_2018-03-28_12-01-40.png
so why would it show unlimited??

Bear in mind also that there are users showing the correct limits (from the DB settings). this was only after setting and then removing personal limits for that Mailbox.
0
Riaz Alexander AnsaryEnterprise Infrastructure Systems EngineerCommented:
when you use Get-Mailbox to get the Quota it is usually shows the default unlimited. but your true Quota settings are always being picked from the database settings where the mailbox resides.
  • check if the mailbox get its Quota from the database by:
Get-Mailbox <Database Name> | fl UseDatabaseQuotaDefaults,Database
if  UseDatabaseQuotaDefaults value is true then you are  getting the quota from database
  • Check the database settings by
Get-MailboxDatabase <DatabaseName> | fl *Quota*
In here you will see the true quota settings. you can use Set-MailboxDatabase to change any of the settings.

if you would like to use the database quota for all mailboxes in that database but have a special settings for one mailbox  you can set UseDatabaseQuotaDefaults on that particular mailbox to false and then use set-mailbox to set the quotas you need for that particular mailbox.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud as a Security Delivery Platform for MSSPs

Every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. View our on-demand webinar to learn more!

motorhogAuthor Commented:
Can you check the first command?? im getting this error,

exchsnip.png
It is referring to my DC not the Exchange server im running the command on??

Also, why would some mailboxes show the correct limits after assigning custom limits then removing the custom ones??

Thanks
0
Riaz Alexander AnsaryEnterprise Infrastructure Systems EngineerCommented:
Sorry that supposed to be Mailbox Name not database name
Get-Mailbox <Mailbox Name> | fl UseDatabaseQuotaDefaults,Database

you should have caught that yourself :)
0
motorhogAuthor Commented:
So basically, all my Mailboxes have UseDatabaseQuotaDefaults = true. But they show as unlimited in the script but are not.

Outlook is reporting correctly as having the limits. I will have to see what happens when someone gets near a limit.

Many thanks for your Help.
0
Riaz Alexander AnsaryEnterprise Infrastructure Systems EngineerCommented:
Glad it was helpful please mark as solution if it was  helpful.

what happens when someone gets near limit you can see all that in the database settings and change them as you need.
0
motorhogAuthor Commented:
Thanks for your Help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.