• Status: Solved
  • Priority: High
  • Security: Public
  • Views: 50
  • Last Modified:

Remote Desktop Services won't install, (reports needing reboot regardless of rebooting)

I am trying to set up Server 2012R2 to allow 6 people to RDP into it.  I have bought the 6 per user cals.

After installing RDS role via server manager.  I am stuck trying to configure.  I have rebooted 3 times.

When going through the Add Roles. ( logged on as Domain Admin)
 ) I select Remote Desktop Services Installation
 ) I select Standard Deployment ( I also Tried Quick Start).  (Drop down only has the 1 local server)
 ) I select Session-Based Desktop Deployment
 ) I select only machine listed (localhost)
 ) Install RD Web Access Role is checked
 ) Server is selected for Server Pool

BAM, "checking Compatibility" windows pops up saying server has Pending Reboot.
I have rebooted several times always coming back to this same point.

I could "exclude" it, but it's the only server and needs to be configured, so that shouldn't do anything.

How am I supposed to continue?
0
Dwight Crane
Asked:
Dwight Crane
  • 3
  • 2
1 Solution
 
ITguy565Commented:
please check the following key and post what is there

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations
0
 
Dwight CraneIT ManagerAuthor Commented:
\??\C:\Windows\pxisys.ini

\??\C:\Windows\pxiesys.ini

\??\C:\Windows\agPxiCfg.ini

\??\C:\Windows\ktPxiCfg.ini
0
 
ITguy565Commented:
This occurred because you tried to update a hardware driver and didn't reboot after the application update.

Here is a process for Symantec, but you can follow the same process in order to recover for this..

Please backup the registry keys you are modifying. I would do this after hours and make sure you are local if you don't have a CMC you can log into.

Open the Windows Registry using regedit.exe.

  • Search for the entry "PendingFileRenameOperations" in:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Session Manager
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\BackupRestore\KeysNotToRestore
If you find the entry, first back up each key, and then delete the entry in each key.

  • Search for the RebootRequired key:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
  • If you find the key, first back up the key, and then remove the key.
  • Restart the SEP installation; the install should finish without error.

here is the source article :

https://support.symantec.com/en_US/article.TECH98292.html
0
 
Dwight CraneIT ManagerAuthor Commented:
So there was a program that was essentially reinstalling itself every reboot, so the values were getting repopulated.  I uninstalled the program then I was able to delete those keys without them reappearing.

Thanks
0
 
ITguy565Commented:
Awesome, Glad you got it resolved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now