SG300 Combining VLAN Trunks onto LAGs

I'm setting up a set of SG300 switches to support an added VLAN and to support  LAGs.
The LAGs should trunk the VLANs.
A simple case would be like this
Upstream (3-port) LAG Trunked <> Switch <> All of the other ports Trunked.

This is what I see::THis looks OKYet, when I've tried to set this up, the Port VLAN Membership shows like this:VLAN 100 is Tagged in LAG1 - seems rightAnd, it appears that the VLAN 100 is tagged on LAG1
But, the ports belonging to the LAG (16,17,18) are sowing Excluded in Port to VLAN hereIs this normal?Is this last one normal?
LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
If you can telnet, ssh to device - CLI show running would be more easier to read.
I guess it is OK since VLAN 1 and 100 are listed under LAG1, but I never worked with GUI of SG200/300 devices.

It should be listed in cli running configuration as (or something similar):
interface Port-channel 1
 switchport mode trunk
 switchport trunk allowed vlan add 1, 100
switchport trunk native vlan 1

vlan database 1,100

Open in new window

0
Fred MarshallPrincipalAuthor Commented:
Pedrag Jovic:  Thanks!!
I see this:
interface gigabitethernet15
 switchport trunk allowed vlan add 100
 lldp med disable
!
interface gigabitethernet16
 description "Teller LAG 1"
 channel-group 1 mode on
 lldp med disable
!
interface gigabitethernet17
 description "Teller LAG 2"
 channel-group 1 mode on
 lldp med disable
!
interface gigabitethernet18
 description "Teller LAG 3"
 channel-group 1 mode on
 lldp med disable
!
interface gigabitethernet19
 switchport trunk allowed vlan add 100
 lldp med disable
!
interface gigabitethernet20
 switchport trunk allowed vlan add 100
 lldp med disable
!
interface Port-channel1
 description "OPS LAN LAG"
 switchport trunk allowed vlan add 100

Open in new window


What is unfortunately perhaps called "Teller LAGn" where n=1-3 is the cable numbering for LAG1.

Ports 15, 19, and 20 are just bracketing entries.  They show "switchport trunk allowed vlan add 100" and nothing about VLAN 1, the default.
So that seems consistent with the LAG entry "switchport trunk allowed vlan add 100".
I rather get that "ports" means "individual non-LAG ports"  and any ports included in a LAG are subordinated to the LAG being treated as a "port" so to speak.  That's why ports 16-18 in the LAG aren't treated on the "Port list", eh?

I need this to work as there will be little time for "adjusting" during testing.
0
JustInCaseCommented:
Interfaces 16-18 are part of Port-channel 1 (command channel-group 1 mode on is configured on ports).
Port-channel interface is "taking over" all from individual ports (except some details like buffering). For example, there can't be mac address list under individual interfaces - it is function of LAG... etc...
switchport trunk native vlan 1 - is not seen since it is default (can't be seen on any other trunk too).
Cisco is not showing many default commands  to make configuration easier to read.

show interfaces port-channel 1 - should how you more details about LAG

You can check more details:
Cisco 300 Switches for Release 1.3.7 - Port Channel Commands - page 438

Recommendation is to use LACP if both sides support it (to avoid network loops if misconfiguration happens - mode auto instead of on). If LACP is active on any side, both sides must negotiate LAG otherwise interface will be disabled until other side starts "talking" LACP.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Fred MarshallPrincipalAuthor Commented:
Thanks!

If the configuration is a simple cascade tree of switches then it's hard to imagine network loops.  Is that right?

Then is LACP still recommended?  Is there a downside to it?
0
JustInCaseCommented:
Since you have LAG there and no control protocol, misconfiguration of one port in LAG (from any side) can cause loop. Downside is that negotiation needs to happen and it take some amount of time (typically, less than second), but it removes risk of network loop (so practically - there is no downside).

You're welcome.
0
Fred MarshallPrincipalAuthor Commented:
I've implemented the LAGs with LACP.  All seems to be working fine!!
Thanks!
0
JustInCaseCommented:
You're welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.