Corrupt USB?

I have been working on a file from a USB drive for a couple of weeks. For some reason all of a sudden when I insert the USB drive it tells me I need to format the drive before using it. I have been using it on my windows 7 workstation. I really need the PDF file I have been working on. Is there anything I can do to retrieve it? I have tried the USB on different workstations with no success.
InSearchOfAsked:
Who is Participating?
 
dbruntonCommented:
You'll need to try a data recovery util.

There's PhotoRec  https://www.cgsecurity.org/wiki/PhotoRec  which isn't intuitive to use but might be capable of doing the job.  It is free.

GetDataBack  https://www.runtime.org/data-recovery-software.htm  is commercial.  Free to try, if it sees your data you pay for full functionality.
0
 
JohnBusiness Consultant (Owner)Commented:
I have tried the USB on different workstations with no success.

So the USB key is damaged.

Do you have the file on your PC from an earlier time that you can resurrect?  

Failing that, you would need to try a local recovery agency to try to recover the file.
0
 
Sam Simon NasserIT Support ProfessionalCommented:
this message appears on your computer only or  ALL computers? if appears on all computer, then you need to format and recover the data.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Tiborg GuaranaIT beginsCommented:
Try to connect it to non windows OS.. that could save your day :)
0
 
nobusCommented:
check the usb stick connections - i've had some that came loose, and resoldering them fixed it
is it an USB drive, or an USB stick ?
when you connect it  - do you hear the welcome sound ?
does it show in device manager  - perhaps in error?
0
 
Sara TeasdaleCommented:
There are many instances when your USB flash drive gets corrupt or throw you an error message leaving you to deal with it.

http://www.recover.mozesoft.com/data-recovery/windows-data-recovery/
0
 
JohnBusiness Consultant (Owner)Commented:
@ InSearchOf:   By now you have tried recovery. Anything worked?  Please let us know.
0
 
InSearchOfAuthor Commented:
Thanks for the useful suggestions. I was able to recover some data but not all. Luckily the data I was able to recover was sufficient. I used the the utility suggested by dbrunton. Thanks a million.
0
 
nobusCommented:
you're welcome
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.